Not able to override Unit-Format via the Properties: Linear Dimensions Panel

I made detail layout that I wanted to dimension differently than my primary layout which is in feet-inches and set via the Annotation Styles in Settings. Drawing units are inches.

I though I should be able to do this by selecting the dimension, then in the Properties:Linear Dimension Panel in the “Length Units” section I changed “Unit-Format” to “inches factional”. No visible change to my selected dimension. I tried with every other imperial measurement choice and none of them worked. I am able to use the same property panel to change everything else I’ve ever tried, arrow style and size, font style and size, text location, zero suppression and probably others without any issues. I tried selecting a different dimension and changing its Unit-Format and could not.

Is this a bug or is it a limitation or is there something I need to have done prior in order to setup to be able to override my dim style defaults?

Edit: I found something that seems to cause this behavior above. Or at, least I have found a way to get it to work right.

Note that I run two additional monitors off my iMac. I have the layout with the detail I am trying to override the dimensions on my iMac and another monitor has the actual drawing the layout was taken from. On that monitor I also had the Properties:Linear Dimension Panel open since I have the top panel always set to “show properties panel.” If I disable the “show properties panel” on the drawing window, I am then able to change the “Unit-Format” as I expected to.

For the curiosity of it all, I re-enabled the “show properties panel” in the drawing window and then again was unable to change Unit-Format in the layout window.

Another thing I noticed is if I try to get the dim style I want by selecting “Template Inch Fractional” as the dim style it won’t work right either, until, I unshow the properties panel in my drawing window then changing the style will work right. It does seem as though maybe it is not only “Unit-Format” that was not working of the template. But I would have to play with that more to know for sure.

I now am pretty sure has got to be a bug.

Hello - thanks, as far as I can see this is a bug.

It looks like it is fixed in the V7/WIP.


Hello Pascal,

Thank you for checking into it. The link you included does not seem to work for me.

Sorry - that first link should be public now - sorry about that.