No localization data when installing?

I had problem installing the new Octane 4 version in Rhino 6. At their forum I found that someone had succeded in installing Octane 4 for Rhino 6 if you uninstalled Octane and Rhino 6 completely (deleted folders and registry) so I tried it. It didn’t work so I tried installing Octane 4 for Rhino 6 manually and it worked OK. But now I found out that when I made a new install of Rhino 6, there are no templates. I believe that the localization data was not installed with the 6.10.18311.20531 version.

Hello - can you please try running repairing the V6 installation? In Windows’ Control Panel > Programs and features, locate Rhino 6, > Modify, in the context menu > Repair.


I did and it made no difference.
And there is no Localization folder.

You might want to try “Change” instead of “Repair” (if you see that), then press the gear wheel icon on the splash screen and check to see if any languages are checked to install, if not check one or two and proceed.

There is a setting somewhere that got set before you cleaned your installation and reinstalled Rhino, and it is preventing Rhino from putting back the render content. To get it to show up:

  1. Open the Registry Editor:
    a) From the Start Menu in Windows, type RegEdit, then press Enter
  2. Browse to HKEY_CURRENT_USER\Software\McNee\Rhinoceros\
  3. Delete the folder named 6.0
  4. Start Rhino

to be crystal clear here, there are actually two locations in the registry related to Rhino 6:


You need to delete the second one.

I did that too. English was checked and it made no difference.

That’s what I did when I reinstalled.

FWIW and to keep things linked - this is also reported by another user here:

That must be correlated. The folder Localization and all folders under it is missing and there should be both templates and render content there.

If I compare 5 and 6 in the registry there is a key : KeyLanguage in the Rhino 5 registry but not in the Rhino 6 registry. Instead there is a key : install_en

Are you sure? You have to do it manually - the uninstall and reinstall won’t delete the HHEY_CURRENT_USER registry keys for you.

Yes I’m sure.
I uninstalled Rhino 6 through the control panel, then I deleted the Rhino 6 folders in Program data and in App Data and finally I deleted the registry for Rhino 6 in Local Machine / Software.
Then I installed Rhino 6.10 and after that Octane 4.

Just to be crystal clear here, there are actually two locations in the registry related to Rhino 6:


Did you delete both?


Now I deleted the HKEY_CURRENT_USER\Software\McNeel\Rhinoceros.6.0 key and this made everything work again. Problem solved!

1 Like