No Geometry - Enormous File Size

This is weird. I just copy to clipboard one curve from one instance of Rhino and pasted it into a freshly opened, brad new file in second rhino instance. And it’s size jumped immediately from 56k to 2.6 MB… Why…?

Looks like 3 large bitmaps came along. I saw this using the Audit3dmFile command. I don’t know why this would happen. If I do the same with your file, the result is 14 kb. Maybe you have a plug-in running that I don’t. I’ll ask around in the morning. I see there is a test command called TestPurgeBitmapTable. It seems to take care of the file size. It’s probably safe, but since I didn’t write it I have no idea what harm it may do.

Thank you Chuck. Test command works. And so far no pain… if you need anything more from me I’ll be happy to help.

Can you send me ( the file from which you copied the curve?


File send. Thank you

Thanks for sending the file. I can repeat the problem and should have an explanation shortly. It could be that the bitmaps were assigned to the curve for some reason, which would cause them to follow the curve when you copy it.


It looks like one of our plug-ins, possibly RhinoRender, thinks it needs to include those bitmaps with your curve. I’ll put it on the bug list.


Well all bitmaps in this file being used as picture frames. Few of them have been imported into rhino and than I used flow along curve to make them follow lines describing deck sheer. The only thing is none of those curves were ever exported. Curves that I copied and paste were all different from those. Hope this helps.

Thanks for the information. I’ve included it in the report.

000EmptyBugBig.3dm (11.3 MB)

Hello List,

I’m facing the same problem. I run Rhino version SR11 32-bit (5.11.50226.17195, 2/26/2015) and when loading a file whose entities have been deleted and then a new layer was made, made current and all others have been deleted I still have a 11MB file. The original file was made under Rhino 4 and then saved as Rhino 5. You can find this file attached.

I tried the following:

  1. SaveAs, no plugin data. No difference
  2. SaveAs, geometries only. It works, but all entity attributes are lost
  3. SaveAs, small. No difference
  4. Purge all. No difference
  5. History purge. No difference
  6. Delete my custom plugin and reload Rhino. No difference

The I performed these simple analysis:

  1. From task manager get the allocated ram by the Rhino process before and after loading the file. The difference matches the file size
  2. Zipped the file itself. No significant difference.

It look lime there is am internal recycling bin which I can’t empty or there are memory licks which are saved in the file itself.

Any idea?

Thanks. L

Try typing TestPurgeBitmapTable… 24Kb. HTH, --Mitch


it works perfectly!

Thanks. L