No export/import "tool palettes sets" possibility in the command editor


#1

Hello
It seems that there is no possibility for export/import tool palettes sets in the command editor. These strings (in the upper-left menu of the command editor) are inactive (gray). I want to save my shortcuts list, if it is possible.
Thanks.


Feature possibility?
Feature possibility?
(Dan Belcher) #2

I believe you have discovered an unimplemented feature. I have logged a bug track item (MR-2315).

I presume what you want to do is move your customized tool palettes to another computer? Is that correct?


#3

almost. i’m going to reinstall OS and I’d like to save my stortcuts list


#4

If you want to save your Aliases you can export them to a text file and then install from that text file. Use the gear wheel in Alias under Preferences.
Probably not exactly what you are looking for but just mentioning it.


#5

Thank you for filing this request, Dan!!!

In the meantime, is there any way we dig under the hood to at least see a list of our custom commands? This would be really helpful for reference.

(I tried looking in Library > Preferences > com.mcneel.rhinoceros.plist file, but failed to locate anything that resembles the name of my custom Command Set.)


Feature possibility?
#6

I can at least confirm that transferring the plist (following this procedure ) does not transfer any command customization. I recently used that method to customize Rhino on a second computer, and checked if a known command icon modification came across. It did not.
(@DigiFabLab: it finally dawned on me what you meant by “custom commands”, you are talking about command palettes , or maybe customized command icons? Afaik you cannot introduce new Rhino commands, or change their functionality)


#7

Yes. Viewing the Custom Tool Palette Sets for the Keyboard Shortcuts (created or modified by the user) is what’s desired. Not icons. (Rhinoceros > Commands > Customize. Dropdown menu at top left. My example below is named Default DC).

If we can’t Export our custom Tool Palette Sets now, at a minimum it would be VERY helpful to somehow get this list for reference. Digging under the hood in a .plist file or some other gimmickry would be totally fine for now until Export is enabled. (I’ve been asking for this Export for at least a couple years now, so I’m not optimistic that it’s “just around the corner”, but maybe?)

@dan: If there is a way to access this list, it would be great if you could point us to it. (Scrolling through the list and taking multiple screenshots in the Command Editor is the only alternative currently, and every time one makes new custom commands, one has to rinse and repeat…)

~Dave


#8

Hello
I can’t duplicate the default shortcuts, the duplicate button is gray and inactive.
Thanks for your help


Command Set Duplication - Gray
Command Set Duplication - Gray
(Dan Belcher) #9

There is a bug in 5.1 on El Capitan that was causing duplicating custom command sets to crash Rhino for Mac. We worked on solving this bug before release and were unable to. We are still working on it. We decided that - rather than have 5.1 on El Capitan crash - we would release it with the Duplicate button disabled. This was a “lesser of two evils” decision.

The good news is: when we do manage to fix the crash bug, working with customizing command sets on El Capitan will go MUCH faster than it did on Yosemite. Cold comfort, I know.

We will release a fix for this in an update as soon as possible.


Command Set Duplication - Gray
#10

Thanks for all !


#11

I had the same problem Janlou14,

But since I had access to a computer with OS X Yosemite, I created another command set in that and edited it in my El Captain.

It is very slow but I could work with the editable profile.

Here is how you can find the preferences file.

Here is a file with a editable command set.
https://dl.dropboxusercontent.com/u/9544660/com.mcneel.rhinoceros.plist

Be aware that all your other settings will be restored with this new profile, so backup the original.

This is not perfect, but it is a way around until they fix this!


#12

Thanks Filipe I try it.


#13

Is there an update to this bug? My Command Editor>Default>Duplicate is still greyed out. Not having my preferred tools handy is a slow way to work…


(Dan Belcher) #14

This bug will be fixed in the 5.2 update to Rhino 5 for Mac (no timeline for that yet, unfortunately). However, at the moment, you can use the RhinoWIP to customize your command tool palettes…since Rhinoceros and RhinoWIP share preferences, changes made to custom tool palette sets in RhinoWIP will show up when you launch Rhinoceros (5.1).

We apologize for this inconvenience.


#15

Good day!
I’ve installed 5c83w WIP and have confronted bad behavior of newly created commands:

  1. Create new modified pallet
  2. Create new command in it (*_Offset Pause t) for example; give it a name - “Multiple Offset”, assign hotkey - “cmd+F”… All is good for now and I can see it in the lower left icon list of commands.
  3. I press “save” button and having fun with new superior macros.
  4. Come back to the command editor - and now I don’t see it in the command list, only in the modified pallet, which I’ve created. Close editor. Command still works.
  5. Go back to the editor and create new command in the same modified pallet - *Circle, hotkey - cmd+shift+F
    Now I can’t edit properties of created “Multiple offset” - double click doesn’t work as it does on commands, which were created in previous versions.
  6. Come back to Rhino - last command works but not the previous one.
  7. Close Rhino, open it again - neither of these commands work, but they present in the modified pallet, but not in the icon list in the left corner of command editor.
    Same behavior in the stable 5b161 release. OS - 10.11.2
    Maybe I have messed conf files… or is it bug?

(Dan Belcher) #16

This sounds a lot like MR-2377, which was reported in this discourse thread. Are there any key differences in behavior in your report? I retraced your steps and it seems like MR-2377, which is a known bug. Thanks for reporting!


#17

Thank you for pointing, Dan!
I’ve found, that I have different behavior in step 4
Caveats:

4 Search for Foo…“Foo” appears in the All Commands list.

It doesn’t in my case. It works (can run it with shortcut) until I relaunch Rhino.
Also, from time to time, it is impossible to edit custom command right after creating it. Double-click on command’s text box does nothing.


(Dan Belcher) #18

The latest RhinoWIP has some new commands that should help here:

ExportPreferences and ImportPreferences

…please give them a try and let us know if these do the trick.


#19

It looks like ExportPreferences doesn’t create any file on my El Capitan 11.6
Sorry for writing that (
I’ve checked that I have free space on disk and see hidden files in Finder.


(Marlin Prowell) #21

We see this. This will be fixed in the next WIP release.