No color in my renders just grayscale


#1

Ive updated Flamingo to nXt 5 and when I render my project all i get is gray-scale, no color. Anyone know why? I’ve gone back to Flamingo nXt and I get color. Any help


(Vanessa Steeg) #2

Hi,

Can you give us more details? Does it happen with older models that come from nXt only or new models too? Does it happen if you create a new material in nXt 5.0 or does it only happen with nXt materials? Also, if you can share some screenshots, it could be helpful!


#3

Hi Vanessa, Thanks for replying. I just tried rendering a model I drew yesterday and it looks beautiful. The model i’m trying to render is really complex but only a few weeks old .Here’s a pic of whats happening.The Pic of the frame you can see the dark part is supposed to be a gloss orange.


(Vanessa Steeg) #4

Hi Reggie,

Thanks for the added info!

What happens if you render it with the Rhino Render? Do you get colors? Also, is it only happening with this model? What happens if you render something else with nXt 5.0?

If it’s happening only on this file, maybe you can post these two parts so we can take a closer look at it.


#5

Rhino render and nxt 3 work fine. It might just be this model. I tried some other models this morning and they render OK. But this was happening from the beginning on this model. So far only chrome and black gloss work.


(Vanessa Steeg) #6

In that case, can you send us the file? You can send it directly to us (support@mcneel.com) if you prefer.


#7

Here are pics from renders. I rendered in nXt3 and nXt5.

The last pic is everything removed except the frame.How do i send you the file?


#8

BTW 15m pixels @ 5 passes.


#9

How can I send the file? Email and this site say its too big, even after I zipped it.


(Scott Davidson) #10

OK, there are a few problems with this file.

  1. The main problem with the file is in the rendering window under Adjust Image, the Saturation slider has been set to 0.00. This will make the image black and white. that is there reason there is not color. The default value is 1.00.
  2. The model is very large, but should not be. Setting good mesh setting and purging the model took the file from 197 MB down to 2 MB.
  3. The resolution of the rendering is set up to 5000+ x 4000+. That is very hi for test renderings. I recommend dropping that down to get faster test renderings,


#12

Could you please explain #2. This model is drawn to scale. It is meant to be built in real life when done. Also #3 I use a high render scale to see the best quality, making sure it looks as real as possible.


#13

BTW, Thanks for your help.


(Scott Davidson) #14

When importing a model from a larger STEP file there are many blocks created. Block are instance objects that live in the header of the model. So, when the objects are deleted on the screen, the definitions for blocks may still exist in header of the drawing. This can create a very large model. The Purge command can clean out the model gheader. There is more information here: https://wiki.mcneel.com/rhino/usingblocks

I can understand the higher resolution for a final rendering. Can that is a good idea. But, whaile working on the mode and testing materials, lights, etc… I recommend a much lower resolution until everything is ready for a final rendering.


#15

OK, thanks again for the information.


#16

BTW, I’m not importing(only 1or 2 small objects) . This is all drawn in Rhino 5. Is there a way to scale the model in R5, like 4:1.


(Vanessa Steeg) #17

Hi @Reggie, you can use the Scale command to scale your model. Select the objects you want to scale > set an Origin point for the scale > at Scale Factor, type 4 and it Enter. Let us know if it’s something else, you’re looking for.