New Style Grid in Rhino

Hello, Im wondering if there is a way to go back to the old style Grid in Rhino? This new Grid system just doesnt work for me?


New Rhino Grid style

Go to Options>Rhino Options>Colors and choose “Restore Defaults”

Thanks for your quick response but I’ve followed your suggestions and the layout of the white grid lines remains? Is there another approach? Im really confused as to why this new grid layout was created? The old style worked just fine.

Thanks again,


I’m not sure what you mean. This is how it is supposed to look at default:
just like it has been for 20 years I guess…
If it looks different at your side, run _SystemInfo and post the result back here

If you look at the screen shot in my original post, you will see that the lines are not as they are in your screen shot. Here is the system info:

Rhino System info 4_4_21.txt (2.68 KB)

Forgetting about the colors, here is another screen shot showing the strange grid layout?

New Rhino Grid style.jpg

To me it seems just that you have set different colors, the grid itself is just the same. What happens if you restore it to the factory default colors?


Im confused as to why you think the grid is the same? It is not even close to being the same on my pc laptop? I’ve reset the colors to the factory reset but its inconsistent grid cell size that’s throwing me?

This is not what Im used to in Rhino nor is it like the example that you sent me?

Thanks again for your help. Im sure this is some simple setting that Im missing?



Rhino rectangle example.jpg

The only thing I think that is off is the background color. Now the major lines are almost the same as the background color and this gives the appearance of missing lines.

Maybe I’m misunderstanding your posts, but it looks like the colors that the viewport background and grid are set to are causing the illusion that there incorrectly sized items in the grid. You are pointing at the major grid lines which have their own color setting.

Are these the colors that you have set up in your options?

Have you modified your display mode to have a different viewport background color?

I’ll look forward to wip v8 window ver dark style such as mac~ :confused:

Hi Steve,

Thanks for your help. You’ve solved it for me! It was the display mode options that you highlighted that was the culprit. Once set back to application settings, everything looks right again!

Thanks to everyone else that reached out as well!