Network Surface not working?


For some reason, the network surface command is not working for my selected curves. I think it may have something to do with the caution window I get when I first run the command that says I have “over 100 curves.” In my command history, I get a message that says, “Unable to sort curves. Select curves one at a time.” Basically, when I run the command, no surface is generated.

I have attached my file. The curves that I’m talking are the green ones you see and are in a layer called “profile.

Can someone please help me out?

VolumeScaled.3dm (387.2 KB)

I’ve just found the same thing. The status bar says, “Sorting curves…” and never completes the operation. Checking the log, it does report “Unable to sort curves. Select curves one at a time.”

I get the same result whether i’ve selected 2, 3, 4 or more curves to make a surface.

5A745_NetworkSrf_test.3dm (42.3 KB)

yeah, not working here either.

your model is weird anyway… two of the curves are actually 60 curves… a quick fix to get that taken care of is to select everything then run _Ungroup

i haven’t investigated further as to what’s going on in the file but doing this will give you the proper count of 28 curves instead of 146

I’m glad it’s not just me, but the next build can’t come soon enough! I use NetworkSrf a lot!

I see this. Thanks for the detailed report. See MR-1666 for updates.

Thanks for the update, Dan!