NetworkSrf difficulty

I am trying to create a surface out of these curves, but for some reason Rhino (in both Mac & Windows) is unable to display the surface created. With “Preview” on, nothing is showing up. it shouldn’t be an issue with the points not intersecting, because I wouldn’t get the dialogue box in the first place, right? I’ve also gone through and checked that every point hits the bottom edge curve. Any thoughts?

Note: the screenshot is taken in the Mac version because I was trying to see if it was a hardware error and switched to Mac. The problem occurs on both platforms.

.3dm file added
141120_networksrf issue.3dm (168.3 KB)

Post the 3DM file, please.

I just opened the file and NetworkSrf worked fine on my machine. Win8 64bit Rhino 5
Preview worked fine also

All my best … Danny

On a relatively old Mac version (build 517 2014-6-30) that I still have, I don’t get a preview, but if I deselect, then re-select the preview checkbox, the preview appears and everything works fine.