Network Srf Not following Curves

Hi everyone,

Seeking some help with a Network Surface command on grasshopper.

Frustratingly, the surface won’t follow the curve surface. I tried baking the curves and using NetworkSrf in Rhino and it worked as expected.

Here’s an image of the situation. Green is the curve input and red is the surface output. Note in the red circle the deviation from the green curve.

Furthermore, this surface is the bottom of a two part shape. I had no issue using the same curve for the top surface on GH.

I’ve also included a script that only has the curves & NetworkSrf node below:
NetworkSrf Not (6.5 KB)

Thanks in advance for the assistance!

I don’t see any variations between the curves and the surface but my settings might be different from yours. It’s common to see anomalies in GH that aren’t there when you bake the surface. There are several places that affect this including (in GH) ‘File | Preferences… | Viewport | Course/Smooth preview meshes’:

And ‘Display | Preview Mesh Settings’. In Rhino, check ‘View | Display Options… | Mesh’ (Jagged and faster vs, Smooth and slower).

Your curves have many control points, which affects the NetSrf. You might want to rebuild them?

1 Like

My understanding is NetworkSrf first effectively rebuilds the input curves as curves with the required parameterization and knots/control points, and then creates the surface from these rebuilt curves. The Rhino version of Grasshopper allows the user to specify tolerances for the deviation of the surface from the exterior and interior input curves. Tighter tolerances can result in more control points. The Grasshopper version of NetworkSrf does not appear to have user set tolerances.

The native grasshopper Network Surface component uses the Rhino document absolute tolerance.

If you want to use a different tolerance, you can use a simple script. (15.7 KB)


1 Like