Need HELP Bug on the Z axes, always at 0 in the perspective window

Hello to you
I have had a problem with modeling for a few days. Already when I draw in the perspective window, for example with a polyline, the point is always hooked at the zero level of the Z axis. Same when I move the mouse cursor all around. On the X or Y axis no worries but the point does not move from the coordinate 0 on the Z axis. Similarly when I test an extrude elongated curve on a circle for example too, the generated shape is always deformed, it is flattened on the Z axis.
I hope you can help me with that , it’s very annoying, I can’t even work on my rhino 3d
Thank you for your answers

Hello - see if the setting for ‘Project’ is on in the object snaps:


yes i already checked the osnap. But it doesn’t seem to come from there. I spent a lot of time looking for the different Cplane options but it doesn’t seem to come from there either

Hello - if you snap to an object off of the CPlane, - for instance the top corner of a box… does that work?


yes I can snap the box, it works but the next point if it is outside the box, returns automatically returns to hook at 0 coordinates

Hello - if you want to keep the next point at the level of the previous one rather than drop back to the CPlane, set Planar on (Bold) on the status bar -


Ok that’s for the drawing itself. But when I want to make an extrudealongsurface for exemple
a part is found flattened in certain areas. Do you have solutions for that please ??

Hello - if you mean Extrude curve > along curve, that is the expected result from that command - use Sweep1 for the effect you are after.


I really mean to extrudre a circle along a curve, or extrude surface along curve , that’s what I’m trying to do for a project And obviously there is a problem somewhere that I can’t fix. Thank you anyway for your help pascal golly

Hello - please try Sweep1.


I tried the sweep1 an I have good results of what I expected, thanks a lot Pascal