Nasty Bug with render mesh in layout details

We are getting a nasty bug where all of our isometric layout details in shaded and arctic view styles are having random render mesh elements disappearing. So parts of surfaces are disappearing and we can see through to surfaces behind. It is worse in Arctic but shaded does it too. Its happening on multiple computers and multiple files so we are assuming its a bug.

I’ve already tried ‘ClearAllMeshes’ but it just changes where the dissapearing surfaces happen

Any help on this would be appreciated as we are unable to print to PDF right now

Thanks

Moved to Rhino for windows

Hello - if you hide the objects that shade correctly doe the bad ones change?

-Pascal

Seems like the unspoken rule that “if you ask IT for help the problem will solve itself when they show up” has extended into this time of Social Distancing. After hours of this bug happening when I open the file again to try your suggestion everything is working fine. I’ll let you know if/when it comes back how hiding objects affects things

1 Like

OK its back.
I tried turning off the objects that rendered correctly and it didn’t fix the bad ones. If anything, it got worse.
I am using large blocks so I tried exploding them but it didn’t fix the problem either.

The issue affects every view style.
The issue shows up even after a reboot.

I have found that if I open a clean instance of Rhino and open the file, at first the views will render correctly. However, very quickly the views start to get screwed up.

Interestingly, if I print to PDF right after opening the file then the PDF pages will look OK initially but the further along into the document the views start to get mangled.

It feels like a memory management issue. But I could be way off. I have wondered if using Remote Desktop could be making the problem show up, but its just a guess.
any suggestions that I can try would be appreciated.

Thanks

Is the model far from the origin? If so, try moving it close to the origin and see if that makes a difference.

Its a big model but the geometry that I showed above is right near the origin

Hello - can you please look in Properties, with no selection, in that view and make a note of the camera and target locations, and distance to target?

-Pascal

Here is the camera info:
image

We’ve been using this file for months and had no issues until very recently.

Thanks - Hm - I don’t know that this is a factor, but a camera to target distance of

69433.5

is pretty large - I just wonder if in views (if any) where this is not a problem the numbers are similar. Also, what that distance is compared to the size of the scene overall.

-Pascal

Pascal,
The model is in millimeters so the target distance is only 69m. My model is over 100m long.

Interestingly, If I open the drawing and try to print every sheet into a single PDF then the mesh goes berserk, but if I print one sheet at a time it seems like the model doesn’t blow up and all the prints turn out clean.

I also watched my GPU memory (2GB dedicated, 16GB shared). After opening the model I stepped through each layout. As I viewed each layout my GPU memory stepped upwards and nearly hit the limit of my dedicated memory. After viewing each layout it was at about 95% utilization of my dedicated GPU memory and my shared memory is 0%. At around 80%-90% of the dedicated memory the mesh issues start to show up. If I just print one sheet at a time then the memory doesn’t bloat and the errors don’t appear in my model or PDF.

I’ve tried updating my display drivers, but it sure seems like there is at least some correlation between memory and these issues

OK this is definitely a Bug,
It took me a while to figure out a way to confirm this because we just had a service release updated so most computers are running on the same release (Version 6 SR25 6.25.20084.7001, 3/24/2020) regardless of if they are running the Service Release or Service Release Candidate.

I did find a computer that is still running the previous version (Version 6SR23 - 6.23.2055.1311 2/24/20)) and everything works just fine. The render mesh doesn’t have holes and printing to PDF results in clean PDFs.

Hopefully that helps you figure out what got changed. Please let me know if you need any more information to fix this bug.

Ian

Well, yes… and only .069 km, but it is the number of digits that counts, the units matter… In any case, just to eliminate some possibilities, can you please run SystemInfo and post the results? If you can isolate a subset of your file that shows the problem, I’d love to have it (tech@mcneel.com) and if not, the whole thing (please SaveSmall, Zip and upload to www.rhino3d.com/upload to my attention, with a link back here)

-Pascal

I’ll work on getting permission to send you the file.

My system Info is below:

Rhino 6 SR25 2020-3-24 (Rhino 6, 6.25.20084.07001, Git hash:master @ 8ccca232f2cb9a607dcd428479aed111ef16d078)
License type: Commercial, build 2020-03-24
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name:

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro K2000 (NVidia) Memory: 2GB, Driver date: 2-24-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.50

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-24-2020
Driver Version: 26.21.14.4250
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.25.20084.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.25.20084.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.25.20084.7001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.25.20084.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\import_GHS.rhp “General Hydrostatics (GHS) Import”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Thanks - can you verify that the problem still shows if you (with only one Rhino open) disable Vray in Options > Plug-ins and then close and re-open Rhino? Just making sure cause we’ve seen some pretty peculiar and seemingly unrelated behavior associated with plug-ins.

-Pascal

Disabled V-ray. Did not fix the problem.

Hi Ian - I did get this to happen for just a moment in the file you provided. It seems to be dependent on the level of zoom in the layout, but I can’t yet find the combination that gets it there.
I notice two things so far when I hit a layout that shows the problem -

  1. if I pan the layout view the detail redraws correctly.
  2. It appears to print correctly even if the layout display is wonky.

In V7, the display reverts to correct after a moment of ugliness. It would be interesting to know if you see any difference in V7/WIP.

-Pascal

For me I found that after opening the file everything will initially look correct. I have to click through every layout before things start to blow up and persist. I just tried it to make sure dumbing down the file didn’t cause the bug to go away. This morning, by page 14 the Isometric detail in the upper right corner is obviously messed up.

Regarding V7 I’m still getting the X-ray bug that I told Steve about awhile back where all my perspective views look like they are in a combination of the actual viewstyle + X-ray. So its hard to say if things are working right for me in V7. I’m using (7.0.20091.15085, 03/31/2020) just in case the in-house version you have has had that bug fixed

I gave V7 a try again and it seems like the xray bug has been fixed, so I was able to properly check to see if things work in V7. Unfortunately the ISO views blow up in V7 exactly the same as in V6.