Named View Crash

Every time I tried to save a named view, rhino crashes. I see there is a similar thread from 2018 running rhino 6, but I’m running Rhino 7 on Windows 10, looking for a solution.


In every file or just a specific file?
If it’s the first, run _Systeminfo and post the results back here.
If it’s the latter, these would be the first things I’d try:

See if there are any bad objects in your file (_SelBadObjects) and remove or repair them.
Make a new file and import your file into the new file and see if the problem persists.

It’s hard to say, there doesn’t appear to be any rhyme or reason. If i open a new blank file, it’s fine. Same if I open an old rhino 6 file. I don’t know if I have many rhino 7 files but the two most recent that I’ve been working on, having nothing at all to do with one another, crash when I try to save a named view. I tried as you advised, but there was no bad geometry.

Hello- please run the SystemInfo command in Rhino and copy/paste the results here.


Rhino 7 SR13 2021-12-7 (Rhino 7, 7.13.21341.05411, Git hash:master @ 45edb3f0b4f8cd1af41e883b112aea508d01118e)
License type: Commercial, build 2021-12-07
License details: Stand-Alone

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 1.3e+02Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 10-26-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.47
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-26-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 11 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Geometry Gym\Rhino3d\BullAnt.rhp “bullant”
C:\Users\bdb\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot10RhinoPlugin (ccedd9da-83b9-429a-aec5-8ec90b85fe67)\\KeyShot10RhinoPlugin\Rhino 7\KeyShot10RhinoPlugin.rhp “KeyShot10RhinoPlugin”
C:\Users\bdb\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\TeDAsharp (ce983e9d-72de-4a79-8832-7c374e6e26de)\1.0.6981.15425\TeDaSharp.rhp “TeDAsharp” 1.0.6981.15425
C:\Program Files (x86)\Evolute\EvoluteTools LITE for Rhino 6\EvoluteCoutHook.rhp “EvoluteCoutHook”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.13.21341.5411
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.13.21341.5411
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.13.21341.5411
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\bdb\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2020.12.9.865\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.13.21341.5411
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.13.21341.5411
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Disable third-party plug-ins and see if it still happens.

i’ll give it a try, but that’s really not a solution seeing as how i need those plug-ins.


You’re not looking for solutions yet.
You’re trying to identify the problem.
Once identified, then we move towards a solution.