Move mesh with curves and objects without mesh highlighted?

Hi, I am unable to proceed at all, 24hrs .
posted in a thread but no replies so hope it gets seen here.
Also other users might find this useful and spot it.

I have a mesh, I draw some lines on it, and some solids, I need to move it and get those lines to marry up with another mesh with similar lines, I cannot see a thing as all goes yellow and loses me sight of the reference lines.
I am about to enter the world of drawing decent geometry over meshes, rescaling mesh, doing this above quite often.

How can I move the curves, solids and the mesh and only have the rhino made items go yellow whilst doing so ?

Perhaps there is a mesh selection properties setting where selection indication colour can be made almost zero, just enough to know its been selected.
Changing colour to e.g. cyan for mesh selected wouldnt be of use as the myriad of mesh lines and solid cyan glow would hide any yellow lines !

I also find that just selecting a mesh and dragging it sees my ortho direction using shift want to misbehave, whilst on a rhino item it works perfectly, I need to do a short distance knowing it was true ortho then hit tab, why does mesh make this so tricky ?

if there is no mesh selection subdue colour setting, how best can I do mesh moving ?

Cheers Steve

It appears your selection method is selecting all objects. Are you clicking on the mesh in an area away from your drawn curves? This should select only the mesh and leave the curves unelected and in their original color.

You probably checked the “Shade-highlight selected meshes” checkbox in Options - it is displayed with yellow color in the following screenshot.

To uncheck it, run Options command… Options > View > Display Modes > [Mode Name] > Objects

(I would do all editing in the wireframe display mode.)

Hi Steve,

you can try if this script helps:

It toggles selection highlights for ALL objects in current display mode, mostly helpful when working with dense meshes.



1 Like

Dear @Steve1
not sure about the transition you re trying to do - but what about predefining the movement with a line,
the line will define start and endpoint of a movement - and therefore will define a vector.
so it is independent of the positon…
(1a) instead of move from point A to point B
(1b) draw a line from A to B
(2) move the line somewhere out of the drawing A’ to B’
(3) select the mesh
(4) move from A’ to B’ (which is the same as from A to B)
hope i explained somehow understandable.
kind regards

1 Like

I’ve had a similar issue as Steve when working with very dense meshes. When a mesh is selected and is highlighted other objects are difficult to see, even in Wireframe model. My solution is similar to Tom’s.

Create a reference point or points at the key locations on the mesh, and at the corresponding new locations. These points need to be on a different layer than the mesh.
Start the command such as Move, Copy, Orient, Orient3Pt, etc.
Select the mesh.
Turn off the layer containing the mesh.
Select the reference points, etc as needed to complete the command.
Turn on the layer containing the mesh.

Hi guys,
Terry, I have my sections through the mesh and some drawn items grouped to the mesh so they move en-masse.
I click the reference curve and the mesh goes selected as well, as expected.
If there was an option to have mesh not highlight and curves etc to highlight, that would be useful.

Andrew, that tick box is already unticked.

Jarek, many thanks, the toggle selection script is useful, the curve being snapped to when using move command goes yellow, whilst the rest stay as if untouched, but it all is in fact selected, I can then move it and no blinding yellow mesh.

I cant see the curves though as in wireframe or shaded mode the mass of triangles gets in the way.

I wish one could make translucent the mesh and the texture it has. is that possible ?

so, …
I also did what you said David, have my sections/traces, and other drawn items on a separate layer, but grouped to the mesh. Move the curves with mesh layer turned off, and after move turn mesh layer ON, and mesh has moved with it. As long as grouped, layers dont need to be on.
you dont mention group but not grouped would leave the mesh I thought.

Tom, David,… I have sections all varying a bit so I am dragging for a visual best fit, so placing a line representing the exact vector route is not practical. I have posted asking how does one get an average curve from 7 curves. That would give me a more finalised source and destination, a move, a rotate, an orient 3 point all perhaps needed to match up.

I look at this dense mesh, and can see areas I just dont need that density. Back in Metashape I decimated mesh but found it lost me detail areas, .

Can rhino decimate a mesh and keep the fine polygons where the detail matters, lessening it on planar surfaces etc. This seems a fundamental need in decimation, yet everything is treated as if it all needs decimating, I want the fine detail areas untouched really. …or must this be done in the source program which has the photos to make a texture from ? I dont think metashape has that ability, its failing on texture making as it is, a bug, and not being fixed though. Perhaps meshlab can refine it in the manner wanted.

Having applied texture jpg to all views and my mesh, one window is making it purple, the layer colour and not the jpg and when I zoom in I see a jpg through the purple mesh lines, whats going on , how to fix that ?


maybe move a copy of the cyan objects till they fit. - including a simple bounding-box-base plane.
after the copy matches nicely to the mesh, move the mesh back according to the translation between cyan original and cyan moved copy. ?
check out _pointDeviation tool ! very nice to feedback deviation for this kind of workflows.

Hey i’m pretty sure you said you already unticked it but can you try unticking ‘mesh wires’ in appearance tab. I work with dense scans a fair bit and it works for me.
mesh wires unticked:

mesh wires ticked:

1 Like

I am afraid that this is the limitation now - even with disabled selection highlight, the “ghosted” mesh wireframe of the original object position when moving will always show, and with dense meshes it will cloud the view, regardless of any user-accessible display mode settings. That’s why having a silhouette selection mode would be great…
I would sometimes move things first far away, so when I move them to the desired precise spot, the “orginal location” dense mesh ghost does not get in the way.
Definitely this is Rhino’s limitation when working with dense meshes. If we could have a switch to turn off the ghosted “orginal location” when transforming objects, it could help, combined with the disabled selection highlight method.


on meshes here again, I have my imported .obj, I have allocated the jpg the obj has with it, to materials, by object cocolour, browse to image. It shows fine texture.
I have used setObjectDisplayMode and chosen rendered.

I have unticked show meshes, also under objects unticked ‘shade highlight selected meshes.’
The script gives me an error.

I wish to rotate it.
click the object and I see a myriad of yellow meshes still !
is there no way to stop this yellow mass of mesh triangles from appearing ?

To be able to rotate it and see it in its true appearance and not a yellow mass is essential .
I cant draw on it and move the drawn items , with visibility of mesh layer off, when its at an odd angle and size.
once I have it orientated I can draw on it.