Model not visible in Front and Top View, but visible in other 2 views?

Hi, I’m pulling my hair out! I can see my model in the Perspective and Right Views but it is invisible in the Top and Front Views. I know they are there as when I select an object in either Perspective or Right View I can see the selected outline in the Front and Top Views.

Any enlightenment would be much appreciated!

What display mode are they in?
It’s possible to suppress the display of different object types in the individual named display modes.
Go into Options - View - Display Modes, and see if any of the names are lavender, indicating they are not using default settings.
I think you’ll find it.
One exception to that are dimensions. Dimensions will vanish by design when the viewing angle is very flat.

Hi John,

Thanks for your very prompt reply. Some were not in default modes, so I clicked and made all view settings default. Unfortunately, they still cannot be seen except when I select the object in the Right View point when I can then make out their outline.

Maddy

Hi vanvr- please check the Properties page with no selection and one of these viewports active - are the camera and target locations reasonable? or huge?

-Pascal

1 Like

Hi, I think this is the problem. Y location is negative with a huge number. How can I reset this?

Hi vanvr- most likely, there is an object that is very far out in space. Try, in one of the other views, Zoom Extents - does the view zoom out like crazy? If so, probably the part of the model you care about is on one side of the viewport, but tiny and the other object, whatever it is, is on the other. Try making a window selection around half the viewport- if your model is highlighted, use Invert followed by Delete. If your model is not highlighted, but the command line reports a selection, just Delete.

Any luck?

-Pascal

2 Likes

Pascal, Yes thank you! All fixed and some hair left in tact!

Maddy

Hi @pascal. I have encountered the same situation today. All views are OK except Front, which displays only the 4 Clipping Planes. I have only started using Clipping Planes today, so that might be a clue. I have tried the suggestions that you and John provided above without success.

image

I tried to shift the camera to 765,1000,265.5. After Placing the camera for Front, the negative Y location setting remained active.

image

I had created 4 Clipping Planes - Top, Right, Front and a copy of Right angled at 45 degrees. I tried deleting the angled plane, but Front view still did not display the model.

All views including Front select the same set of objects. Although Front view is correctly positioned for all selected objects, I cannot select any model objects in that view, either by swiping or by SelectAll. SelectAll only selects the 4 Clipping Planes.

The Front view below is positioned using Zoom Selected, and it has correctly made space tor the model objects, but they are not displayed. They are all selected. You can see 2 of the 4 Clipping planes towards the bottom. The other 2 are out of view to the left of the green z axis.

I have restarted Rhino 6 and I found Objects are invisible in one of the views, so I also restarted Windows 10, but neither are helping.

I have detrmined that it is due to the Clipping Planes, but I am not sure why. I proved that by starting with an old copy of the model, deleting all objects, copying into it all objects from the problem model except the Clipping Planes, then copying the Clipping Planes one by one. The Top CP is OK, but the others prevent the Front view from displaying the model.

Rhino 6 SR33 2020-12-5 (Rhino 6, 6.33.20340.21001, Git hash:master @ dc3074cfd26cb57b879a6e486e45c2af932a7620)
License type: Commercial, build 2020-12-05

HouseRemodelZHTP3ap4V6Clip.3dm (411.9 KB)

I found Clipping plane bugs and switched to 4 viewports as suggested in the April 2018 posting. The Front view then showed the model. However, even if I save the model and reopen it, switching to Front view results in the model being hidden again.

Regards, Garry.