Middle mouse botton lose control by causing extrem zoomspeed

Working with Rhino6 and Grasshopper several times (I can’t explain the reason) the middle mouse button zoom became uncontrollable, the objects on Rhino screen are disappearing even by one small rotation of the mouse button. (The Home button is not setting back the view to the previous state in these cases.)

I have tried several recommended action learned from the forum:
- Changing the zoom scale factor in View Option less and also more than one.
- Check/uncheck the reverse action checkbox,
- Select existing objects and zoom selected object.

These actions sometime helped to setting back the normal way of work, sometimes not.

This phenomene is very annoing and hindering my work.

I have Windows 10 home, AMD Radeon ™ Pro WX5100 grahic card, Logiech M705 mouse and K520 keyboard, ASUS 16GB Ram, Intel I7-7700K processor, 2 Philips BDM 3270 monitors.
I have installed the newest drivers for all o f my hardware.

I have never experienced this with Rhino5.

I woud apprechiate if someone would advice how can I solve this problem.
Thanks in advance!


Does this also happen when you are not using Grasshopper?

Yep. I’ve experienced this. AFAICT it’s the mouse driver (Setpoint). Very buggy driver IMO, but unfortunately nothing more recent is available for the M705. Under certain conditions you get a “runaway”. I also frequently find the MMB menu function that I programmed in Setpoint gets deactivated.

In general what solves it here is launching Setpoint, you don’t even have to hit OK on the opening screen afterwards, just cancel, the driver resets itself and the symptoms disappear.


I always use Grasshopper, so I can’t answer the question.

Thank you for the advise! After opening and closing Setpont, the symtom disappearred. I hope it will solve the problm permanently!

No, it won’t unfortunately (in my experience). So you might need to make something to have quick access to it when the craziness occurs… You could even call it from inside Rhino with an alias or toolbar button:

_-Run "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Logitech\Mouse and Keyboard\Mouse and Keyboard Settings"


Thanks a lot Mitch!
You are my gest for a beer in Hungary! Let me know when you are here!