Meshing Extruded Objects

I have seen this (problem) since many years and would like to ask about it.
When I mesh a extruded object like the one in the image, setting maximum edge length
does nothing. the mesh faces are always long skinny faces.
Is there something I am missing here ? I need small triangles and not those long edge ones.


that’s because you are meshing extrusion objects. it works ok in normal surfaces:

You can use _ConvertExtrusions to turn all your existing objects into regular surfaces or polysurfaces.
If you don’t want to use extrusions anymore you can disable them from Options > General> Use extrusions when possible.

Thanks Diego
Well I know I can convert them, my question was about the mesh tool.
If I am asking for a mesh on a extruded object with a edge smaller than a value.
The tool could do all this in the background or no ? (convert to a brep and mesh it correctly )


Hi Gerry -
We have that issue on our list as RH-60249.
I’ve added your report. Thanks,

The basic idea of extrusions is to get a “light-weight” object (regarding data-size) and as far is i understood also meshing is one of the bigger parts of the data in a standard .3dm file.
(if you “save small”, rhino will not save meshes, and recalculate them on opening).
So this concept only makes sense if the mesh-command respects it.

So extrusions will help you, if you model a house or half a city for example, with a lot of wall s etc … all extrusions … so you have a smaller file size, and less work for your graphic card.

Extrusions as object-type is not a modelling feature, it is a data-management-optimization
as al extrusions can be converted to Surfaces / Polysurfaces
there is
_useExtrusions as a general setting
_convertExtrusions to help you for special cases where you need other meshing.
for all other operations e.g. Boolean stuff, trimming, … rhino will handle everything in the background for you.
hope that helps, best, -Tom

1 Like

Hi Tom
I know that extrusions have been added to make lighweight objects.
For this reason i want to keep them but if i am asking for a mesh its because i need one
Meshes are saved (rendering meshes are not with save small).
So if i have to convert a extruded object to a brep to have the mesh i want, i have to
a) convert to brep
b) mesh it
c) reconvert to extruded (to keep lightweight model)

I know how to make the mesh I need trough a script, my question was just about
the mesh tool that seems broken to somebody without all this knowledge.


dear @wim and @gerryark

in difference to geryark’s initial post, it seems there is concerns for other users “without” all this Knowledge.
For me it seems like an option in the mesh command would answer gerry s need / question:
“allow reduced tesselation for extrusions”: yes (default as is) / no (“for Gerryark”).
But as the meshing options are already quite complex - maybe just a info in the help-File ? - only use extrusions if you want / can accept their special meshing-Behaviour ?
have a nice day everybody -tom

Hi Tom
Clear but the option is already in the mesh panel. If the max edge length is zero then you keep the behaviour as it is. If I set it to a value smaller than the extrusion length then clearly the tool has to mesh correctly