Materials turning black/white/purple in a rendered viewport

My problem consist in materials turning black, white, purple or disappearing in the rendering viewport.
I transferred my work from a laptop to a computer through a transfer server named WeTransfer. After I saved my project, I discovered that all of the materials turned black or disappeared. I thought that it happened because I didn’t have the used materials saved on the computer, so I deleted all of them and imported new PBR materials from the internet. Unfortunately, the problem still occurs, the materials are not seen correctly in the render viewport, but, if rendered, they will actually appear.
Also, I work with Rhino 7 for Windows.

Hi Cristian -
Please run the Rhino SystemInfo command and copy-paste the result here.

Rhino 7 SR12 2021-11-9 (Rhino 7, 7.12.21313.06341, Git hash:master @ 5590153808223b57a9f41516a969fd949aa81bff)
License type: Evaluation, build 2021-11-09
License details: Stand-Alone
Expires on: 2022-02-26

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 8Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: AMD Radeon R7 200 Series (AMD) Memory: 2GB, Driver date: 8-21-2020 (M-D-Y). OpenGL Ver: 4.6.13596 Compatibility Profile Context 27.20.1034.6
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 8-21-2020
Driver Version: 27.20.1034.6
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins that do not ship with Rhino
C:\Users\rosca\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\AMDDenoiser\0.5.2\AMDDenoiser.Windows.rhp “AMDDenoiser.Windows”
C:\Users\rosca\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.3\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows”
C:\Users\rosca\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.1\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi -
Thanks, that doesn’t look too bad though a bit underpowered and there’s probably a newer driver for that GPU.

Could you post a simple file with just a few of those objects that are not displaying correctly?

Sure, but how can I copy a few of those objects in a new file? Should I also import the materials, since the problem concentrates around them?

Hi -

Yes, you need to make sure that the file renders correctly as you wrote in your first post:


It says that the file is too big to be uploaded.

Hi -

If you only have 1 or two objects in that file, how big did it become?
You can always upload big files on Rhino - Upload to Support - make sure to copy the url to this thread in the comments field.

I tried to upload the whole file. As I said earlier, I don’t know how to move just a few objects from that file to another.

I figured it out.
Objects.3dm (1.0 MB)

When I said that I figured it out, I meant that I discovered how to upload a few objects from the original file to another one.

Hi @wim
I’ve run into this too.
I reported this but couldn’t repeat it in my thread with DP on…

Multipipe woes and wishes


Hi! I still encounter problems with the materials. I’m waiting for feedback.

When you save your project you should ensure the Save Textures option in the save dialog is checked.

The couch object turns black when the bump texture can’t be found.

I’ve always had the Save Textures box checked.

The file you shared did not have all textures included, which leads me to believe you did not have the setting checked.

I ran into this again and the textures were assigned and present.
This time perhaps to due to the model being small the black object was able to change back and show it’s texture again.
I’m thinking it might be a resource problem or Rhino gets stuck and the pipeline balks at redisplaying the textures?
The way I cured it was to go from rendered mode to raytraced then back to rendered. But it I am seeing it once in while. Maybe something to do with subd objects rendermesh as well since I see it on those objects the most.

Can you perhaps show me? I don’t think I understand. When I save the file, the Save textures box is always checked.

I get this when opening your file, which means that the textures were not embedded. When during saving Rhino asks if you really want to embed supporting files you must answer yes. You have many large textures references, according the file names. You should end up with a file much larger than 1MB.

The sofa is black on ignoring the mssing files:

When I disable the bump channel the sofa looks better

It will look better also with the correct texture in the channel when the bump channel is enabled.

I deleted all the textures from the file and imported a new one. I made sure that the Save textures box was checked and that I answered Yes when asked to embed files. I still encounter the same problem; the material does not appear correctly if rendered.