Pbr materials

Having trouble getting PBR materials to show in rhino render. When I do a render preview and the final render, none of the materials that I have created appear, and the rendering is simply all white.
What settings do I have to adjust to make sure that the rendering reflects what’s in the model?

how exactly do you render?

in rendered view mode do your materials show? how about raytraced mode?

please run the systeminfo command in rhino and paste the report here-

Hi Kyle–thanks for responding.
Yes–in rendered view mode, the materials do appear. In raytraced mode they do as well.

Below is the report:

Rhino 7 SR25 2022-11-22 (Rhino 7, 7.25.22326.19001, Git hash:master @ 2a680490f96a04550d1f39158b859c4f7739d024)
License type: Commercial, build 2022-11-22
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 12Gb)

Computer platform: LAPTOP - Plugged in [97% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 620 (Intel) Memory: 1GB, Driver date: 8-15-2018 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1
Primary OpenGL: NVIDIA GeForce 940MX (NVidia) Memory: 2GB, Driver date: 12-5-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 527.56
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-5-2022
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins that do not ship with Rhino
C:\Users\louie\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.3\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows”
C:\Users\louie\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.22290.1357

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hello–Im rendering with rhino render and I am using rhino 7 with the latest updates.

are you rendering with enscape, or rhino render? check render>current renderer

often different render engines will only accept their own materials. make sure you are using rhino materials with rhino render, and vice versa.

fwiw, your video card does not meet our system req for rhino 7… you are running 2gb vram, req is 4gb per monitor. You are also running an older driver, it may be worth an update to that using custom/advanced and clean install.

Hi Kyle,

I am using rhino render. Seems likely that the issue is with my computer not having enough enough vram and the older driver.

Thanks very much for your help.

it would be odd for no materials to show up because of that… it would be more likely you get crashes or display weirdness.

check tools>options>plugins.

any chance the rdk is not loaded?

it should look like this with checkmarks/

If it shows with Raytraced it will show with Rhino Render - they are the same engine and night identical barring the very entry point.

You can choose to set CPU as the render device, that way the GPU doesn’t matter for rendering. You won’t be constrained by the GPU VRAM either.

yep, something super weird going on here. I’m wondering if enscape is hijacking something in the pipeline.

I’ve changed to CPU from GPU but unfortunately the PBR materials are still not showing up. The change to CPU also seems to make the render time much longer. Is that to be expected?

Hi Kyle, I looked to make sure the plug ins you mentioned were all checked, which they were. Still not entirely sure of the problem. I do have enscape downloaded as a plug in though I do not have a license for it and am not using it (when I first tried to use it as a trial, I got a message saying that my graphics card could not support enscape). I only mention all of this because you said that you think enscape could somehow be interfering. Do you suggest I try to remove enscape? Thank you.

Please share a (simple) file that reproduces this problem. To be clear, this happens with Rhino Render?

Hi Nathan,

Yes this is happening with rhino render. I’ve attached a wetransfer file. My apologies for the size–I did not delete all embedded blocks but have reduced the amount of geometry and layers in the file.
Appreciate your help on this!

I don’t think that for the three materials used in the visible objects you should be using any subsurface scattering effects. Since they are walls, floors and ceilings it doesn’t make much sense.

Additionally I wouldn’t use displacement maps either. Those need a lot of geometry to work, in your case it wouldn’t even show considering the settings chosen. Stick with the normal maps, that’ll be more than enough.

With the displacement and subsurface scattering removed:

There’s not much difference between the two white materials on the ceiling and walls, so they look quite similar in this quick lowres render.