Materials preview


#1

Both previews blackPreviews not matching anymore even though I made a tiny increase in value only

I made material reflective here and again rendered view and render itself are not matching.

I am struggling to make the render look real. I suppose that this preview issue may be causing it. The rendered view in Rhino look better then flamingo render. I tried to use channels to reduce sky intensity and increase sun intensity but it doesn’t really help that much

original channels adjustedNew folder.rar (19.6 MB)


(Brian James) #2

I’m not able to reproduce the preview issue so far here but the file uploaded is a little different then the one you’ve shown. If you have a simple model with an applied material that the floating preview doesn’t match what the material looks like in Rendered mode and the actual rendering please share that as well and I can try and figure out what’s going on.

The rendering being different looks to me like you had the brightness and saturation turned up in the adjust image section of the Render window. I get a good match here using the defaults as shown below so check that those adjust values are the same as mine.


#3

cube.3dm (45.8 KB)


Reflectivity 0.0001

Reflectivity 0
I noticed that it does that when material reflectivity is set to 0.

I think I uploaded the same file but even after downloading the file from here I am still getting different results than you even though my brightness, burn and saturation settings are the same. I tried to delete environment and set it to default but that doesn’t help.

Reflectivity 0.0001Reflectivity 0

In this last one I used studio lighting preset with default environment


#4

I reinstalled everything on my computer including windows and all the drivers and look what it does. I don’t know if this is just my computer doing all these weird things but I getting tired of it.


I literally just switched ground plane on (with default material) and it completely changed the look of material.

Same thing happening with the model I am trying to work with. I only changed material for ground plane and look at the results. Also where are all those shadows coming from? The only lighting source in the model was sun and sky set on automatic nothing else but it looks as if I used studio preset which I didn’t.

Can you try to replicate some of the issues I pointed at above? If thats just my computer doing this is there anyone who can help me make it work for me? Btw I have antivirus installed so I don’t think that it is a virus …


#5

I used the same values as you but I get different result. Anything else I could try?


(Brian James) #6

I think I might know what’s going on here. The file of the kiosk I had from you did not have the textures in the materials embedded in it and so my renders were without the brick on the wall etc. This has a big effect on the colors nXt 5 produces in the render due to an auto-tonemapper that it uses. This has been the case as long as I can recall and the only way to account for the color changes when textures change is to use the image adjustment values in the render window. See the example below where the render on the top left is a default white ground plane and the lower two renders are with a texture on the ground plane… the lower two renders are exactly the same aside from the image adjustment values on the left.


I think this is the main problem you have run into. The hiding of the ground plane will yet again change the colors due to the auto-tonemapper in nxt which you can’t turn off. Try adjusting these values to dial in your colors after changing surrounding textures.

The material thumbnail preview being over saturated when intensity is set to 0 looks like a bug to me and I filed it here…
https://mcneel.myjetbrains.com/youtrack/issue/FL-6194 thanks for the report, I missed it in the file you posted where the intensity of the red material (I think I made) was not set to 0.

In regards to the overlapping shadows that you asked about, this is how nXt 5 samples the skylight texture to create soft shadows. The method is part of the default render engine used. You can test a hybrid as well as path trace approach too in the render options tab of the Flamingo nxt panel to see the other methods available for shadow calculation.

I hope this helps.


#7

Thank you. It definitely helped a lot. I was trying to fix that renders by adjusting materials but now I understand the issue…I am already getting way better results than before.