Material mapping in Rhino V6 WIP


#1

I’m liking the greater breadth of materials in the WIP, especially woods but I can’t get the grain to rotate correctly… not sure if it’s me or what. I used to apply a surface mapping channel and rotate U-V. the attached image shows my latest creation but the seat grain should be transverse and the deck grain should be at 8 degrees. How do I get the grain to rotate in the WIP? It doesn’t behave like it did in V5. Using an NVIDIA GeForce GTX 970.

-Rick


(Pascal Golay) #2

Hi Rick - I think a planar map from top should get you the right thing - you can rotate the mapping widget to line things up as you like.

-Pascal


#3

Pascal,

Thanks, but that did not work. Rotating the widget did not change the orientation of the material. I was able to do it by creating a custom editable material, then clicking on the color of the material in the property editor which opened a material editor where I was able to rotate the mapping. That seems extreme to me, I’d rather have 1 ‘material’ then change how it’s mapped for individual items. I think there is something I don’t understand here, but I accomplished what I was after;


#4

Seems to be the same as


#5

I have applied a wood floor material and I am not able to rotate the mapping. Z rotation as no influence. I was able to do it in v5. Am I doing something wrong ?

2017-05-04 Rhino6 mapping rotation.3dm (495.1 KB)

Work In Progress
(6.0.17122.11501, 2017-05-02)


(Pascal Golay) #6

Hi Alan - you can rotate the planar mapping widget itself, either with the gumball or Rotate or Rotate3d. Does that do it?

-Pascal


#7

I have rotated manually the mapping widget. The rotation angle is well reported in the z rotation of the mapping panel. But the material is still oriented the same way (horizontal) ; shouldn’t it turn with the mapping widget ?


(Pascal Golay) #8

Hi Alan - can you please post that surface? I’m wondering if you have multiple mapping channels enabled, possibly.

thanks,

-Pascal


#9

Same problem I had. Something is different- it does not act ‘just like V5’.
I have been using Rhino since version 1… As I said, I had to create a new
material and rotate it there.

All the Best,Rick


(Pascal Golay) #10

Hi Rick - can you post a file with an object that shows this? So far here, if I rotate a mapping widget the texture goes along with - maybe I am misunderstanding the complaint…

-Pascal


(David Eränen) #11

Hi Alan,

Did you use a material from the material library? I believe they are locked to WCS mapping in order to get the sizing correctly. Maybe that is why rotation doesn’t work (but I think it should).


#13

Hi David and @pascal

The file I created was in my first post. Here is the link again.
2017-05-04 Rhino6 mapping rotation.3dm (495.1 KB)

This simple file was created just for test to understand what was wrong in a real file. It is just a box with a material from the standard library (wood floor material).


(Pascal Golay) #14

Hi Alan - thanks, I see the file - the floor texture is set to use WCS (i.e. World CoordinateSystem, ignores mapping) - switch that to Mapping Channel 1 and then adjust the repeat (currently Size in my image, for WCS) to 1 by 1 and adjust from there.

Any luck?

-Pascal