Master lighting "reset"

I’ve seemingly created a spotlight while messing with lighting in one of my documents, but want to eliminate it and return to the the “default” lighting scheme, if there is such a thing. Any tips or tricks or commands or settings? I tried to “edit” lights, but no representation of the light source becomes visible. The spotlight or light cone seems a reflection of the camera.

Hi Chris- try SelLight Delete… any luck?


SelLight returns this message: “No objects added to selection”

If I copy the mesh and paste into a new document, I get this in the Rendered view:

I have brought this document through all of the beta versions since the middle of last year or so.

Well, that looks more correct… Are you sorted out then?

Are you going to surface that mesh? Scan? Nice project!


Sorted …? sort of…
This is just one layer of dozens. Do I just turn on all layers, copy and paste into a new doc to reset my lighting issues?
Is there just some artifact in the layered document that won’t permit the “standard” lighting?

This is a multi-year project involving input from several parties.
There has been some surfacing from this and other meshes which are being used to create physical bucks for reconstruction of some parts of the car.

Update: Copying and pasting all objects from one document to another is a fail: “Unable to paste, no Rhino objects or text on the clipboard.”

Hi Chris - if there are no off layers that have lights, and the view projection is as expected in both files, it does seem like the display mode is not being interpreted correctly in the one file. I don’t have any good guesses as to why it is different in one file. Can you please try: SaveAs to a new name, delete everything and add say a sphere- does it also look weird? if so, please send that…


Similar result with lighting in the Saved-As file:

Test lighting file.3dm (270.7 KB)

Hi Chris- did the file ever go through Windows Rhino where it may have picked up some plug-in user data? Here, if I SaveAs, from Windows without plug-in data, the resulting file looks correct, and 8 user data tables are no longer present.


(Checking this with Windows Rhino, so this might be a bit different on the Mac side)

Over here, if I turn off the skylight, it looks as expected.

Often when you have a ton of stuff you are copy and pasting, you need to wait a bit in the file you are copying from until you see the cursor start blinking on the command line before switching to the file to paste to.


Thanks, Sam, I did not think to check skylight.


No, this has only been on the Mac version since I assembled it.

Am unsure where Skylight is found. In a menu or command?

Sam - for this document, no amount of waiting solves my pasting malfunc.

Hi Chris- look in File > Settings > Rhino Render > Basic.


That solves my issue, but is counterintuitive for me.
Thanks for the assistance.