Mapped image doesn't appear in the viewport

Hey Andrew,

I have finally successfully installed Human to apply a texture to my meshed curtain model and got a problem with seeing it in the viewport…whilst the transparency parameter works well…do you have any clue?

Thnx in advance!


you can try playing around with mapping before applying your texture (Human plugin → last tab on the right)

Hey inno,

thanx for your quick reply!
yep I have tried the box mapping and it appears in the viewport, but what I actually need is to apply a custom mapping that uses UV from the mesh output (which comes from Kangaroo component).
I tried to extract UV from my kangaroo mesh using the Shape Diver UV extractor but it just doesn’t give any output…
Whilst Deconstruct Mesh gives me vertices and normals correctly, but by plugging them into Human mapping gives me crazy distortions (which it obviously should, since it is not UV data)

Looking forward to hear from you


your mesh output has no UV information to extract — even if you applied a UV mapping to the mesh prior to putting it thru Kangaroo, I’m sure this wouldn’t be preserved. Is there a surface at any point upstream of kangaroo? you might be able to match mesh vertices to appropriate UV coordinates and use that to set the textured mesh thereafter… but I don’t know enough about your script to say for sure.

hey Andrew!
thanx a lot for your rapid reply!
I could send you my gh file to check if you would find some time for it.