Making a Viewport stay the same size for consistant render output


#1

What is the best way to lock in a viewport? I must have bumped one of the borders and then noticed my renders didn’t match up. I was using an 1852 X 806 window but it changed to 1856 X 809. Is there a way to lock in a viewport size? Thanks…


(Pascal Golay) #2

Hello - Rhino’s viewports are adjusted to a grid when Rhino opens a file - so if the size when saved does not meet the grid it will be close but not the same on reopening - my guess of the moment is that this is what happened in your case.
If you are running V6, you can save a named view (Named views panel) and when that is restored it will take the correct aspect ratio even if the exact size is not the same. Then, setting the render output pixel size should work out consistently (Render panel).

Or you can make a macro that explicitly sets the viewport size before rendering:

! _-ViewportProperties Size 1852 806 _EnterEnd

-Pascal


#3

Thanks Pascal, that is exactly what I’m looking for. How do I go about creating a macro? This is new territory for me…


(Wim Dekeyser) #4

In Rhino Options, you can either pick Aliases or Keyboard to assign a macro to a new command “name” or a keyboard shortcut respectively.

Then just paste Pascal’s command macro (without the typo) in the appropriate field:

! _-ViewportProperties Size 1852 806 _EnterEnd


#5

Thank you Wim… Life simplified…