Make2d Perfect

Hi Greg Arden
In my last test of make2d with last WIP version 1-5-2016 the result is perfect.
Many Thanks
Vittorio

1 Like

Wow, yes.
But the different layers for hidden lines and tangent lines are missing.

Apart from that: Really good!

-C-H-A-R-L-E-S-

And make2d works for meshes too! This is fantastic. So helpful.

Tried with meshes as well now.
The result is really good:

And even better after _SimplifyCrv:

Meant to say _SimplifyCrv could happen automatically.

-C-H-A-R-L-E-S-

4 Likes

Just tested it on a medium sized mesh and it works fine, but I really miss some kind of info when it processes, what stage of how many, some % data, or time spent and time estimated would be really great!

Tested it here. Works great! No redundant lines, no weird tiny segments!

I think you guys at McNeel are just cruel, you’ll put people out of work with such a good tool that requires no cleanup.

Because I’m cruel too I wanted to see if this could work in something really hairy, like a brush with lots of bristles made from curve-piping, then mesh extracted. it took a few minutes, but holy shit!

4 Likes

I’m just hoping that the Clipping Planes will get some attention now…

1 Like

Sweet example Gusto!

I just crashed the WIP on a large file, it didn’t run out of memory, so there are some bugs still, I’ll see if I can track it down a bit.

My wishlist for make2D now is:
1- progress (%) indicator for time estimation (should I terminate or has it calculated 90%?)
((Waiting 10 minutes for an operation to complete is no problem if we know how far the process has come, and that it is still calculating, but waiting 3 minutes with out knowing is a pain)
2- Tolerance setting (no need to calculate in 0.001 mm accuracy if the data is to be printed in scale 1:200.)
3- hatch clippingplane
4- intersections (I do it manually before I run the command if I need it) maybe you could reuse the technical display mode data.
5- group the output based on view.

2 Likes

Can you share that model with me? We do have a couple open issues related to Make2D and clipping planes, but this looks like a good one to add.

On its way…

@brian, here’s another one - continued from http://discourse.mcneel.com/t/make-2d-doesnt-show-clipping-plane/

Make2D in Serengeti also adds two lines that should not be there.
Make2D - Clipping Plane.3dm (476.2 KB)

Hi @wim I wanted to check in with you to see if Make2D in the latest WIP still giving you trouble with ClippingPlanes. I tried with some of the examples given, but was not able to reproduce. Thanks

Hi @rajaa, thanks for following this up!

I first tried with a model similar to the one of which I posted the screen shot above. My ClippingPlane layer was OFF and even though the view was clipped, the resulting Make2D was not. Or at least not as in the view - A layer was created under the Make2D layer for clipped geometry and a single line was placed on that layer but it didn’t have much to do with the way the view was clipped.

I then thought that perhaps I needed to have the clipping plane visible and also selected when calling the Make2D command. I tried that on the same model but then I got an error dialog popping up: A new guard page for the stack cannot be created. Click OK in that dialog box and Rhino disappears into thin air.

I then made a new model from scratch.

  • Two cylindrical parts within each other.
  • Called a clipped named view and called Make2D. (clipping plane layer is OFF).
  • Resulting Make2D has no clipping information.
  • Turn ON the clipping plane layer, select all, and call Make2D.
  • Note - the resulting Make2D output is selected but so is the Clipping Plane. When moving the result to another location, the clipping plane is also moved!
  • The resulting Make2D is clipped but not capped.

For me to consider this function to be working for clipped views, the active Clipping Plane should be able to reside on a layer that is off and the result should be with capped section planes.

Hi @wim
I see what you see. Here is a summary of issues:

  • Pre-selecting geometry: Make2D does not unselect the ClippingPlane (CP), this is a bug.
  • Post-selecting: CP are not select-able withing Make2D command and hence there is no problem with selected CP after the command excutes.
  • Hidden layer for CP (or hidden CP object) is a problem because it is ignored in Make2D calculation. This is a bug.
  • No-Capping for CP is a bug.

We are continuing to actively work on the Make2D improvements and CP is one of the areas that still need some attention.
Please feel free to post any examples that still feel buggy. Thanks

Wim,
If you can send in a crashdump file (.dmp) from the “A new guard page for the stack cannot be created” bug that would be great. Also if you could please describe the step to cause the crash.
If the dialog box about reporting a crash to McNeel doesn’t appear, there may still be a .dmp file on the desktop.
Greg

Hi @rajaa,
Not sure if it is you or @GregArden who looks into this so just mentioning both of you ; )

Just so that it’s still on the list:
http://discourse.mcneel.com/t/v6-goal-make2d-overhaul/10694/93
The file that I sent in that post still isn’t making a curve in the top surface in the latest WIP.

Wim,
I don’t remember seeing this on my bug list so for good measure I added it http://mcneel.myjetbrains.com/youtrack/issue/RH-33309

Greg

1 Like

@rajaa
@GregArden

I have a model here that crashes my PC completely on Make2D.
It was once modelled in Rhino 1, and it is not error-free.

In V5 with this model no problem.

In V6 Rhino eats all available memory, then the paging kicks in, and a bit later the OS crashes.
To retrace:
Load the file.
Make2D
Ctrl+A
…then see.

Will send the model to tech@mcneel.com.

-C-H-A-R-L-E-S-

@rajaa
@GregArden

Good morning,
I have a model that I run Make2D on and it works great, a couple missing lines here and there. But then if I run the Make2D command a second time it instantly crashes Rhino 6 WIP.

I’m going to do some testing with a different file, but I will send you this one. It’s 130mb, should I upload it to dropbox and send you a link or can your e-mail handle that size?

Edit: I ended up e-mailing a dropbox link, under my work e-mail account not the registered e-mail for Discourse. Hope it helps!