Make2d with clipping plane

the result of the make2d with a clipping plane fails.
it makes a outline of the complete part, and ignores the clipping plane.

1 Like

A bit difficult to see just from that image. Can you post a file that exhibits the behavior?
Also post the outcome of the Rhino SystemInfo command, please.

Made a more simpel image.
gray is the model
the green line, is the clipping plane.
the bleu line, is the expected result.
the red line , is the actual result.
It seems like the make 2d ignores the clipping plane.

clipplane.3dm (83.4 KB)

systeminfo.txt (1.8 KB)

Hoi Bart,
I see that - I’ll make sure it gets on the list.
FWIW, When you do one view at a time, it appears to work - that is, the clipping plane is taken into account.

I did one view at a time.
Tried different ways nothing seems to work.

I have now created YT issue RH-46342

As for the 1-by-1 also not working:
When I opened your file, the clipping plane was not set to clip any view at all. Make sure that it is set to clip ALL views that you are creating a Make2D from.

Yes, but i did that just for the image.

met vriendelijke groet Bart

I’m trying to reproduce that here…
Just to be sure, when you open the file that is attached here and run Make2d for the Right view only with settings somewhat like the attached picture, your result is not what you see in the Right View?
clip - Right - test.3dm (84.6 KB)

When I use the projection setting “view” it works well, but fails with “cplane”.
The first and third angle projection fails also.

Thanks for looking into that further, Bart!
The issue with the CPlane option failing is now filed as RH-46346

[The 1st and 3rd angle projection failure is in the bug report that I filed earlier].

Did you already try the plugin “Sectiontools”?
Instead of using the clipping plane, you make your section with this plugin.
Once the section made, you use the “Make2D of Clipped View”

I use clipping planes only for working on my model.
For prints or layout I tend to use “Sectiontools”


I will take a look.

tried the section tools. This works fine, i like it.
But still like to use th emake2d with the clipping for fast sections.

So you want a quick 2dMake of one clipped view?

yes, sometimes its a good view to show a “cut 0ff” view

Further to a previous post regarding Clipping Plane and Make2D. These are 2 screenshots showing 2 identical perspectives in Ghosted mode. The one at the bottom, which is clipped, shows only some curves, produced by the Make 2D command. The one at the top, which is not clipped, show all the curves, as expected. The top view, which is clipped, shows the same thing. Only some curves are shown. By doing the same thing in Rhino 5, I get all the curves correct.

I’m really not sure what I’m looking at in those pictures - you’ll have to provide the 3dm file in order to get help on this.

do you have the tech account at McNeel? Unfortunately I cannot provide the model publicly…