Make2d not working in a big file, could it be because of the size of the file? or maybe its just too many objects?

Hi, Im working on a project and when I try to make2d it just doesn’t work at all, it just produces random lines. So, i’m trying to make2d with the help of the clipping plane command, I have used it before and this is the first time something like this happens. Ive checked my tolerance and have tried with 0.01-0.00001, ive moved the object closer to 0,0,0 and have tried all options in the make2d menu, any ideas on how something like this can happen and how to fix it?

Ill upload some pictures to further illustrate my point:

section of model:
what make2d produces:

plan of model:
what make2d produces:
(its just a random line)

Hello - can you please run SystemInfo in Rhino and post the results?


yes, here it is:
If it helps ive tried to make2d in other computers and the same thing is happening…

Rhino 6 SR21 2019-12-17 (Rhino 6, 6.21.19351.09141, Git hash:master @ 4d373f64ffb55e3a8d607d9618590728d86fb1e9)
License type: Evaluation, build 2019-12-17
License details: Stand-Alone
Expires on: 2020-08-22

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: MSI

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 1060 (NVidia) Memory: 6GB, Driver date: 3-4-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.59

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-4-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - can you please run ‘Check for updates’ in the Help menu, get the latest, and see if the latest SR takes care of this?


Hi Pascal, updating did not work, it still produces a single line (like the one I posted a picture of).

Hello - can you saveSmall, Zip and post the file to
to my attention, and please include a link back here, to this topic, in your comments.


Thank you, I submitted the file

@stmpdd - I have your file, thanks.