Magic Mouse zoom speed sensibility

Working on RhinoWIP (5E199w and before) the Magic Mouse is incredibly sensible in zooming, thus really fast, making it hard to use. Mouse settings in system preferences make it run smoothly on all other softwares (e.g. ArchiCAD, Adobe, and Safari page scrolling too).
Grasshopper has no problems either dealing with the MM.

Is it a known issue?

Thanks

Lorenzo

hi Lorenzo
I realize that what I’m about to write does not address your problem … but … respectfully, please let go of the magic mouse with Rhino. My opinion.

-Simon

2 Likes

:smile:

1 Like

never use my magic mouse for rhino, it just seems clunky and zooming is awful

Yea, there is no ‘magic’…

oh i would not be so pessimistic, if you really want a magic mouse you just have to look for it well enough :wink:

Yeah, I’m switching between the not-so-magic-mouse and the normal depending on what I’m using. it’s frustrating though, I mean with many other softwares it runs perfectly…

still, mcneel would have a look at it?

probably somebody will, during the weekend the staff is rather rare so you might have to wait a bit still.

i use a magic mouse right hand and touch pad left hand and really like the set up

hi Lorzeno,

while setting up my trackpad on my old mb pro i was thinking about your problem once more, the settings in the system is actually different to what you use in rhino and grasshopper anyway behaves different, at least on mac rhino.

so just to be sure, did you check if you have set the scale factor properly? under rhino preferences/view? try setting it to 1 or higher, anything below 1 becomes increasingly faster of course. i have mine set at 0.7 i like it usually fast. but there you can slow down the zoom speed to your likings, see if that helps.

1 Like

OMG!!
I was not aware of the zoom-scale factor parameter!! setting it to above 1 makes it go reverse, but setting it to .98 (it was .90 before) solved the issue!
.99 is a bit too slow, so I guess it’s really a matter of decimals!
thanks RichardZ and all the others too!

oh yes i forgot, above 1 reverses it :slight_smile: but 0.98 is mighty high i would crank out my finger to get where i need :smile: sounds like you still have too much magic in there :smiley: anyway can you remember having such a close to 1 setting before?

nope, I had no idea about that particular zoom setting. when I was using a normal mouse I never had issues, the I guess default setting always worked. but .98 now works great now. lots of magic involved I guess :wink: