(Mac-) Macroeditor (Bug) double-quotes

Answering another topic - i came over the following bug:

To insert spaces in a macro we need (“unisex”) double quotes.
-_SelLayer "Layer 01"

the mac Macroeditor will autocorrect this to
-_sellayer “Layer 01”
with opening / closing double quotes.

this will not run

kind regards -tom

1 Like

@Tom_P I’m not seeing this in either V7 or V8. I suspect it is related to language setting. How’s yours set?

english english
mac os and rhino
mac os x 10.15.7 - (quite old - sorry) ?

I just found this is a mac systems setting. In Keyboard settings, under Text, there is something called “use smart quotation marks” with settings for double and single quotes.

yes it is a system setting.
but it should also be possible, to set it per textfield / UI

so i think the macroeditor should not rely on the systemsetting

not sure if it is exactly the correct hit…
but something like this:

should be set for the MacroEditor.

it is possible to have a single text-window that does not rely on system settings:

just checked:
bbedit does not rely on this system setting.

Textedit does only use it for formated text.
it ignors this setting for unformated text:

Hi Tom, thanks for that info.
I’ve made RH-73307 Macro Editor double quotation marks depend on system settings

1 Like

great - this will make the mac macro-editor more robust…

RH-73307 is fixed in the latest WIP

1 Like