Macro works on pc not so much on mac

I’ve got this marcro saved to a button and it works just fine on the PC. When I run it on the mac. It requires me to select the geometry I want to export, the file type, name etc. I’d like it to be a one click operation where it automatically saves the selected geometry to the file.


! _-Export _Pause

Hi Owen - it looks like you need to leave off the double quotes in the mac version path.


I tried getting rid of the quotes but It doesn’t seem to do anything now.

Hmmm - I saw in the command history, that there’s a double set of double quotes in the output from my test if I include them in the macro and it runs if I do not.
What does the command history (F2) say?


try this:

!_-ExportAll Users/owenkea/Desktop/ PreserveUnits=Yes Unit=MM ViewportBoundary=No Enter

[edit] oh wait… i missed this bit in the original post:
saves the selected geometry

the above exports everything…


with preselected curves, use this:

!_-Export Users/owenkea/Desktop/ PreserveUnits=Yes Unit=MM ViewportBoundary=No Enter

ie- leave the _Pause and quotes out of the macro in the top post.

Perfect that worked. Was it the carriage returns that were breaking it? I also realized you have to restart rhino for changes to take effect. They must be why removing the quoted didn’t seem to work initially.

i think the use of _Pause was breaking it… it doesn’t seem necessary in this case.

also, you shouldn’t have to relaunch Rhino in order for the macro to be recognized… there was a time when doing that was necessary but no longer (at least, i can create and/or edit macros in the latest versions of Rhino for Mac without restarting)