Low surface definition when rendering in keyshot

unhandled

#1

Hi everyone,

I have some questions about the resolutions of surface when you do a loft.

It is supposed to be a smooth surface, and i understand that in the viewport it creates this kind of weird shape to save some resources, however, when i render it in keyshot these weird shapes appear too. (see enclosed picture)
Furthermore we can clearly see that it’s a fractionated curve and not a smooth one. Is it a problem from keyshot or from rhino?

Thanks in advance


Paul


(Brian James) #3

Hi Paul,

As mentioned, the faceted surface you see is the ‘render mesh’ in Rhino. This can be changed by object or globally and you are correct that less polygons in the calculated render mesh will increase display speed while decreasing render times.

In Rhino for Windows you can change the render mesh quality globally using the Options command>Document Properties>Mesh. In Rhino for Mac these settings are found in the File drop down menu>Settings>Mesh.

When exporting a file to render elsewhere, the render mesh will travel with the 3dm format but if you need to use obj or stl, you can adjust the exported mesh when saving to those formats.


#4

What KeyShot version are you using?

KeyShot Pro has a feature called NURBS Ray Tracing. When you import your .3dm file into KeyShot, check the “Import NURBS Data” field under the “Geometry” heading. Then activate NURBS Mode.

31 PM

(Note: NURBS Ray Tracing is not included in KeyShot HD)


#5

If you’re using Keyshot 7 you could try right clicking on the mesh and selecting re-tessellate to see if that irons out the kinks?

Andy


#6

Hi Everyone:

RichardZ and Brian James --> Thanks, so changing the render mesh resolution won’t change the actual file for keyshot. got it.

SHOCKJOY --> that’s exactly the feature i was looking for, unfortunately i have only keyshot HD… :unamused:

2DCube --> Would be great but it’s only keyshot 6


(Michael Pryor) #7

If you don’t have NURBS Ray Tracing then its really not worth it to use in keyshot. The best bet I think is convert to mesh.


(Jakob Normand) #8

Hi @paul_duterque

Actually… If you open your Rhino files directly from Keyshot (importing the Rhino file, not some other file format) or use the Keyshot plugin to trigger KS from inside Rhino, it is the render mesh that is used in KS. So crank up the render mesh in Rhino to “smooth and slower” or custom settings - detaild controls, and you should see an improvement. The custom settings can be a bit of a mouthful, but if you’re doing product design (or similar scale in mm) try setting every option to 0 (which basically turns turns that option off) except for “Maximum distance, edge to surface”. Set that to 0.01 for something like a toaster (0.1 for something like a motor bike or a car). If it’s still showing jagged edges, try putting 100 or 200 in “Minimum initial grid quads”.
The custom settings take a bit of getting used to, but once you get the hang of it, it’s really not that bad!

HTH, Jakob