Low Performance on Maximized Viewport

  • Started after Windows 1809 update (not sure if exactly same time, bu around these days).
  • Happens both on 6.9 and 6.10.
  • It is not about the scene complexity, even occurs with a simple box.
  • It is not about viewport size (as seen in video). An almost maximized view has no problems.

I have been able to work only in 4-view mode for 2 weeks.


Rhino 6 SR10 2018-10-15 (Rhino 6, 6.10.18288.23181, Git hash:master @ 1cd507cf6e8504d40542cec95ec2dab4e2d56e3e)
Licence type: Commercial, build 2018-10-15
License details: Cloud Zoo. In use by: Ufuk Bircan Özkan (Inova Design Center)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: TASARIM

GeForce GPU/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 416.34)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-10-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.10.18288.23181
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.10.18288.23181
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.10.18288.23181
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.10.18288.23181
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\WORKS\DEPO\BİLGİSAYAR\Yazılım\Kurulum\Rhinoceros and Plugins\Macros and Scripts\notilusclipper.rhp “Notilus_Clipper”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\tasarim.INOVA\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.9.26.937\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

Hello - can you please disable VRay in Options > Plug-ins and then restart Rhino… is there any change in this behavior?


Thank you Pascal. Solving a UI scale awareness problem ((SOLVED) Fuzzy/Blurry (extra antialiased?) Toolbars) also solved this issue.