Lost perspective view (and others not 'orthogonal'?


#1

I know I’ve done something dumb with my set-up / settings:

I seem to have lost my ‘model’ in the perspective view, (only)… - other views are ‘o.k.’?

AND / BUT - in other views) I can ‘drag’ it out of ‘kilter’ (out of ‘orthogonal’) - but then I can ‘put it back’ by going to "View => Set View => whatever I want (like “Front”)

this happens with multiple models

I think I’ve done something ‘dumb’ - like, perhaps, altered my ‘settings’ or something else?

can anyone put me ‘back on track’?


#2

use cmd A to select all objects in the scene and use the command Zoom with option Selected that brings the camera back to the objects. you can also call up Gumball if you never used it. it will indicate the location of the objects you can use the Gumball also for moving and scaling the object/s. but in case you have it somewhere twisted away from the camera Zoom Select is always the best choice for this. maybe consider making an alias or use a screen edge with this macro _Zoom Selected


#3

RichardZ,

thanks for the support / recommendation about Select-All and Zoom - I tried both and to no avail, - MUCH Simpler (less ‘hassle’) to just select the objects (only two ‘curves’) and copy them into a ‘new’ model and continue-on - I could never get the SelectAll / Zoom Selected to ‘bring-back’ what I lost - UGH UGH - but I’m ‘trucking-on’ anyway - thanks for your support! Bill


#4

that indeed sounds strange :smiley: maybe you can share this occult file i would like to peep into it. you can also create a new point and with the keyboard enter the coordinate 0 then hit enter, then use SelLast and _Zoom Selected, asuming you have your objects somewhere close to the Cplane you should definitely find it this way.


#5

The simplest way to find "lost’ objects is ZE - Zoom Extents for current viewport or ZEA - Zoom extents all for al 4 viewports. These commands bring all objects into view.

This usually only happens if you hold Shift+ALT+ RMB right mouse button or Shift+Command+RMB. So maybe you are just holding the wrong keys while moving in a viewport.

Like you said, just right-click in the viewport and reset the view, Top, Perspective, Front or Right.

IHTH. «Randy


#6

Thank YOU! - though the ZEA didn’t seem to work, the copy-things-to-new-model-file does work - I guess I really mucked-up something with the perspective view on the ‘old’ one ?

GLAD I had done frequent saves and then copy-the-objects to the new model-file (and then extrude) worked just fiine -

thanks - to both of you - for your considerable HELP!


#7

do you have the “old” file? It would be nice to see what the issue is so you can learn to fix it and not have to copy to a new file…


#8

no, thought I did, but I was doing a ‘rename’ instead of ‘duplicate’ (or vice-versa) - so i don’t have the old file -

here’s the new one, though…

rrr_v14.3dm (3.48 MB)


#9

i guess you found a bug, it does not seem to have anything specific to do with your file. when you zoom out really far till also the gumball disappears, then zooms have no effect anymore. one can select the objects but an error message comes up, Unable to zoom - no objects are selected. you must´ve zoomed out pretty far.

@dan can you have a look at this? this is reproducible with any new file and any object.


#10

No worries, this one seems fine, other than duplicate objects.


(Pascal Golay) #13

I am not seeing a problem so far in the V5 WIP. or release… but I’m probably doing it wrong.

-Pascal


#14

did you zoom back beyond that point where the activated gumball disappears? create a box activate gumball zooooooom out. gumball disappears, zoom select or extends does not work… i zoom back in till the gumball appears voila zoom commands work again. just be sure you zoom still a little more out after the gumball has disappeared. right after it disappearing it still works for an inch or 2 so its kinda the boarder.


#15

Pascal,

I SUSPECT (very much so) it is / was one of those ‘things’ that IDIOT USERS do when they either click-on-something - or - perhaps - scroll-out-too-damned-far (because I can’t (realistically) see anything on the SCREEN - and something happens-somewhere that neither I (nor anyone else) ‘expects’ -

AND YES - from the software-code viewpoint it’s a ‘CHALLENGE’ but from the ‘reality’ viewpoint - it’s easier to draw a box around some things - say ‘select’ / ‘copy’ - open a new model-file - paste - and keep-on-trucking!

A LOT of things in life are like this - - a trade-off - between the mentally stimulating and rewarding exertion of effort to achieve a mentally satisfying ‘find it and fix it’ - versus the GET ON WITH THE DAMNED PROGRAM (and meet your boss’s deadline
(notice how it is never YOUR deadline but always your BOSSs deadline?!

UGH UGH UGH! -

On the other had if I’d had 300 objects, none of which were easy to select, - then - yeah - I’d want to solve the problem but all I had was two sections of railroad track and a bunch of dimensions

thanks anyway - but I hate to waste your (VERY) valuable time!

SINCERELY YOURS, Bill


#16

can’t zoom (back-in) enough - scroll-wheeling and scroll-wheeling all to no avail ? - UGH! -

I SUSPECT I clicked something I should not have clicked - or beeping or booted, or did something
else that an old-grey-hair like me should not have done?

me


#17

:grin:


#18

Just happened with 5.5.2
Trying to solve, I selected everything and exported but the problem does not resolve. Attempting to copy and paste to a new file has no effect due to file size. In the meantime I will try to copy and paste one piece at a time … in the new file …

-Simon


#19

hi @Zsimon i think nobody took this serious enough even to log the bug. probably because nobody ever zoomed that far out. i have found 2 ways to get back into the center of the cplan which should be hopefully close enough to your models, that means if you are having this issue as described -> go to the viewport settings in the right sidebar and input 0 in all x y z location fields then select all objects (cmd a) and use zoom selected. 2nd option create a point with 0 in the coordinate system (meaning call point then hit 0 and enter) which should be always visible, that will guide you back to the center.


#20

Already tried. Nothing. I solved by copying and pasting into a new file.

-Simon