Loss of Mouse button controls

There’s been some slow response on the computer in general and a loss of functionality in particular with a logitech performance mouse. Has anyone experienced this? I’ve settings for the mouse buttons as below and they worked until today.


You mentioned three independent issues here:

  1. It’s slow.
    You’ll need to provide more information for us to help.

  2. Settings in Preferences > Mouse > Buttons don’t work.
    Does clicking a mouse button highlight some label for the command field? If not, something is interfering with mouse button clicks. Likely the next issue.

  3. Using Logitech control panel doesn’t work.
    Using the Logitech Control Panel adds an additional and very complex layer of complexity to managing mouse clicks to Rhino. It is hard to get right. I see you are configuring the Logitech Control Panel for Rhinoceros.app. Is that the program you are running, or are you running RhinoWIP.app?

could it be time to change the batteries?

Nothing Happens at all.

Hi Marlin,
I configured the logitech for the Rhino app. However, I’d downloaded the WIP version and noticed the Logitec control panel changed to it. I deleted the WIP app and it went back to the original.

That coincides with the loss of functionality. Maybe there’s some remaining bit of it that’s confusing the control panel?

I’ve also had an issue with the Logitech control panel losing all the application specific setups and having to reconfigure them. It’s been a real nuisance and I’d like to dump the mouse, but its so very useful when it works. I can program Rhino to respond on it’s own if I delete the LCC control panel, but one of the buttons on the mouse is not recognized in the rhino prefs so I lose it.

Does that help?

As to slowness, that’s been happening in the safari browser I use, so I think its more of a system thing. However, I’ve had a few Rhino lockups and sent comments through the tech report that came up.

The batteries are not the problem.:slightly_smiling:

Update: While we’re at it, I wanted to ask about a ongoing and somewhat strange occurrence which is the unwanted generation of duplicate curves. See attached

ArgoFlex6.3dm.zip (1.2 MB)


I deleted the control panel for the logitech but now when I try to program the mouse buttons, the only option that is activated by any mouse button in the first one.

I have a Logitech Performance MX mouse. I do not have the Logitech Control Center software installed and all four buttons on the left side of the mouse work. They show up as buttons 4, 5, 6, and 9. Perhaps you need to restart your Mac to finish removing the Logitech Control Center.

I’ve restarted at lease twice since then as well as emptied caches and tossed pref files. It’s never been very reliable for me. In fact, I was pleasantly surprised a few weeks back when the mouse buttons actually were showing up in the prefs. After installing the WIP that had grasshopper, things went south and have stayed that way.

What OS version are you running?

The buttons on a Logitech Performance MX mouse work for we using both Rhinoceros 5.1 and RhinoWIP 5C95w, running under either OS X El Capitan or OS X Mavericks.

How did you “delete the control panel”?

You know that’s been a real mystery. For a time all but one of the mouse buttons showed up in the rhino prefs. And for a time they also were programmable in the LCC. I deleted and reinstalled both rhino and the logitec panel but things are still buggy. I purchased a Logitech G700s 910-003584 Rechargeable Gaming Mouse because there’s even more programmable buttons using their Logitech Gaming Software for mac. I don’t believe in ghosts, but I do believe in gremlins.

And the imaginary mischievous sprite is probably staring you back in the mirror. (sorry) This sounds like software and you probably unwittingly broke it via mucking…either the OS or the unnecessary drivers.

I have the MX and a previous incarnation, and both work flawlessly (all the buttons) on more than one Rhino Mac install up to the current WIP, always without any Logitec software installed.

If you can, try it on another computer (don’t install any drivers!). You could try creating another account on your Mac and try that too.

Good luck

regarding the images in the original post:

just so we’re clear…
are you trying to assign commands to mouse buttons via rhino preferences…
…as well as…
assign Rhinoceros specific keyboard shortcuts to the same mouse buttons via Logitech driver ?

[quote=“JKayten, post:8, topic:28576, full:true”]I deleted and reinstalled both rhino and the logitec panel but things are still buggy.

marlin already asked but i’ll ask again…

How did you “delete the control panel”?



I deleted the LCC panel by dragging it along with it’s pref files to the trash. The trash was emptied and the computer was given a cleanup with an app called Cocktail and restarted.

This time round, before reinstalling the LCC, I tried to setup the mouse buttons in the freshly installed Rhino but it wouldn’t have it. But, I’m now able to make an useable setup for Rhino using the Logitec (pain).

Those images in the original post were taken when I was able to use the rhino prefs with the MX mouse. I put the commands in ( )s for reference.

(I’d no idea a gremlin could be so handsome)

Just curious, but what OS are you running at this point?

Presently 10.9.5, 10.10.5, and 10.11.3 (and everything in between at some point in the past) I have a lot of computers at my disposal, an advantage.

Never seen your issue, which is why I suspect a local software issue, but it is certainly not out of the realm of possibility that I am wrong.

To be certain it is not hardware, and short of wiping your Mac at this juncture, try another computer if possible. Install Rhino but not the LCC drivers. If it works, it’s likely ‘your’ software. Another way to essentially “try another computer” is to install Mac OS on any external, and boot from the external, install Rhino on the external. You will benefit from having a clean external boot drive anyway (troubleshooting, etc.)

If above is not possible, again try creating another local account on your Mac to see if such is an issue with ‘your’ local account. You can delete the new account when finished.

Report back…

there’s a Logitech uninstaller that should be in Applcations/ Utilities folder.

try that to uninstall the driver.