Losing the Seam Line on a sweep


#1

I’m drawing a moulding on a fielded door panel, and have done it with a one rail sweep.
Once done, I hide the original curve, but I still have a seam line, is there a way of getting rid of this seam line?

Thanks


#2

visually yes, in your display modes under shaded for example - then general (maybe differ slightly if you have mac or pc) you have to set under the surface edge setting the thickness to 0. you can also save this as a new display mode.


#3

Hi,
I tried that and it does not seem to work.
Would there usually be a line there or have I made some kind of error in my sweep?
I have attached a couple of screen grabs.
I am attempting to move over from Sketchup to Rhino, and these akind of mouldings crop up a lot in my work, so I would love to find a way to get them right.
By the way, I’m on a Mac on the free down load version you cannot save on.


#4

it seems you are showing your isocurves, in your side panel klick on this symbol named objects and uncheck Show isocurves this is for each object individually.


#5

I don’t think it is the isocurves, images attached.
Is there something I don’t understand about direction of the seam, it’s the last option when doing a one rail sweep and I don’t quite know what is does?


#6

looks better now i would say only the seam and the surface edges left which you can rid as explained in my first post. the sweep looks ok to me, there is no real way to get rid of a seam thats a NURBS necessity which you can only set not to show.

to be sure you set that correct, go to your menu bar - rhino - preferences then to display modes, on the left you have for each display modes (wireframe, shaded, etc…) a listing. click on shaded and under the tab general then scroll down to surface edge setting and set edge thickness to 0. be sure you are in shaded mode which you can accomplish by right clicking into the viewport or menu bar - view


#7

Okay, I just figured it out, I didn’t initially get that edge thickness is tailored to each display mode, as you said in your first post.
But the fact that there is a seam line there, is that not bad modelling or is it part of all sweeps that are on a closed circuit as it were. IE Could it pose problems later?


#8

seams are part of closed NURBS. perfectly normal no worries :slight_smile:


#9

Perfect.
Thank you for your help.
I been posted on this forum a few times now, and may post a few more. It is clearly an excellent resource.