Loft not displaying anything when inputting 2 different curve types - Grasshopper in Rhino 6

The attached .gh and .3dm files are intended to start with a polyline profile, make a copy of that profile rotated by a defined angle about the world Z axis, and then create a set of curved surfaces between each segment of the 2 polylines. The curved surfaces are intended to be lofts between 2 arcs. The code works fine when I give the Loft component a set of curves of the same type, all arcs for example. In order for this to create the desired surface however, I needed to use the Tween component to create a new curve between 2 arcs for all but the lowest and highest surfaces between the 2 polylines. So the bottom and top surfaces are created separately. The Tween component creates an “Elliptical Curve” between 2 arcs. So the Loft component is given an arc and an elliptical curve for the bottom and top surfaces. These aren’t showing up. If I bake these 2 curves, they loft fine in Rhino 6. The Loft component also works fine if I give it 2 arcs or 2 elliptical curves, just not a combination of both.

I’ve tried using the Fit Curve component on each curve before putting them into the Loft and it didn’t help. I’ve also tried connecting the Loft Options to the Loft command and tried changing its parameters, but never got the loft to show up.

The Loft components that aren’t working are the 2 furthest to the right on the canvas.

Can anyone tell me what I’m doing wrong? Thank you.

Loft Problem.3dm (37.0 KB) Loft (25.4 KB)

Your curves are not in the same branch on the input, you need to flatten the input (they have different data structures).

Thank you so much for your quick reply. That fixes the problem.