Loft problem

Hi there,

I have a problem with creating a loft in Grasshopper. I am joining every parabolic curve with a half-circle one. Everything looks fine when I look at all the curves that are joined (they are ordered). Maybe a problem with curve directions?

Thanks in advance

loft_forum.gh (15.7 KB)

Here’s a simple solution.

I don’t know anything about how the GH/Rhino functions actually work, so I can’t explain why this works. But I have used this approach many times when working with Loft surfaces.

loft_forum-bb1.gh (28.6 KB)

1 Like

Thanks !
The rebuild curve fonction works perfectly. :slightly_smiling_face:

Problem with lofting curves

I am facing similar issues while lofting various curves. Someone please help with this issue. I have tried searching for the problem and a way to work around it and haven’t yet found the solution. The curves from grasshopper when BAKED could be lofted well in RHINO (ref image : White colored object made in RHINO).
Regards, Kartik.

Dynamic Surface Between Two points_v1_KGD.gh (29.1 KB) Dynamic Surface Between Two points_v1_KGD.3dm (361.6 KB)

Welcome @Kartik,

Judging by the screenshot, your curves seem to have the wrong order! Your issue is a little different from @joseph.henry’s, where the curve seams weren’t aligned properly.

26

When setting/importing, if you preselect a collection of geometries in the Rhino viewport and Set Multiple Curves in Grasshopper, your selection order isn’t respected. Instead, the curves are sorted by creation date and time (?), if I remember correctly. This isn’t a bug, though. It’s just how Rhino/Grasshopper deal with geometries.
Now, if you start in Grasshopper, click on Set Multiple Curves, and then select the curves in a certain order, your choice should be respected, and thus your curves should loft as expected.

thank you , for the reply @diff-arch . I shall try out your suggestion. Hope it works. Thank you.
-kartik