Loft isn't producing surfaces between two clean -seam adjusted- curves?

Hello, I have a small question which I need help solving and can use the information provided to learn more about the loft command.

I have two closed curves, which I have adjusted the seams so that the seams are the same vertice for both curves. The loft command works when the curves are parallel to the CPlane, but do not loft if I rotate the top curve so that it is not parallel to the CPlane.

If I bake the curves and loft in Rhino, it works and does it correctly, but the loft component in Grasshopper isn’t working. I need it to work in Grasshopper so I can make continuous, live adjustments to the loft.

I have also used the “Loft Options” component in grasshopper with different settings, none of them worked.

If the Image I upload is not enough, I can upload the .gh and .3dm as well.

Better to just upload without asking (:

Kind of looks like there’s some tree structure going on(the loft is producing two surfaces) try flattening the input of the loft component?

1 Like

Funny, I had tried different variations of flattening but they all caused problems, must have missed this one. Flattening did produce a loft, and after I flipped one of the curves, I got the results I wanted. Thank you!

Edit: I’m still curious why the bottom curve command produces a different type of data than the top one. I’ve uploaded the files if anyone can enlighten me. (10.9 KB)
aga_2018.3dm (307.1 KB)

Debrep adds another layer. Say you have a bunch of boxes {A;B} half inside of list (0;0) and another bunch inside of (0;1), to make sure that each box has it’s own list of vertices you need that extra layer {A;B;C}. There was a great reply by @DavidRutten recently on this topic.