Loft between planar, directional aligned curves is not planar

Hi, I am trying to generate several lofts between planar, directional aligned curves. Unfortunately, my resulting breps are not planar, but I do not know why.

Thanks for your help! (9.6 KB)

Your curves are so obviously not planar. :man_facepalming:


this is strange… Why is my test for planarity different to yours?

I do not know what I am doing wrong :see_no_evil: How can I get planar surfaces between the curves?

The original curves are planar, when I test them with the “planar” component.

Moreover I do not know what you want to show me in your seconde picture. Of curse the polyline can not be planar, but the individual segments can be planar. I am very sorry when there is a missunderstanding and I would be very thankful if you can explain what you mean.

A single line defined by two end points is “planar” but two lines are not necessarily co-planar, which is required for lofting a planar surface. Your surface segments are extremely close to planar. I tested them by means I’d rather not go into right now, but I’d call it done, close enough, and move on.

When I understand correctly, you recommend to move on with the actual result.

The problem when I continue with the resulting surfaces is, that some are not planar. You can see this when you look at the loft output. I need them all planar for my later actions (not just mathematical, also grasshopper type “planar surface”)

As @Joseph_Oster wrote your curves are planar, but they dont belong to same plane, so they are not coplanar…

So you can project bending surfaces to aproximized plane.

Then move it to correct position so you get continuos brep.

This is a workaround. Or you can go back in process where you got those curves and see if it is possible to get them as coplanar. (16.1 KB)

1 Like

Hello Jakinta,

let us go the “clean” way.
The curves are developed by the latest solution you produced at this threat:

The curves you are starting with are co planar, so I think the inaccuracy is generated by your latest solution. Do you know a solution for this way?

Unfortunately no, i do not know. I dont think it is even possible.
But maybe somebody more proficient than me on this forum might find better solution.

…And surfaces created by above mentioned solution V5 are actually planar…just checked them…

1 Like

The problem happened when the curves were created, outside of this model. Each curve has three to four control points and somehow. the pairs of curves (control points) are not co-planar.

Corrected below in white group but frankly, this and everything about this model, is a bit ridiculous:

  • Separating them into two sets instead of creating them as matching branches in a data tree.
  • Flipping curve directions instead of creating them consistently in the first place.
  • And now this white group to Pull the flawed curves to planar surfaces.

I’m surprised that Brep Join on the resulting surfaces still works, but it does. (15.2 KB) (DEPRECATED, see below)

P.S. I would call this a coping response rather than a solution. But if it must be done this way, after the fact, it can be done better using Project (to plane) instead of PlaneSrf (with arbitrary dimensions) and Pull. (disabled purple group) (15.0 KB)

1 Like

Let me check that again… :sob:

FYI, this thread continues elsewhere: (22.9 KB)