Location reset every time i close rhino 7

Hello. I am setting my location on Earth to have true shadows in my building, but every time I close and reopen the file the location reset back to the USA. Is that a bug?

Not a bug.
If you notice, in Rhino Options, where you set the Location, that’s in the Document Properties section of the list.
That means the setting is stored in the 3dm file, and initially established by the Template file you are using to seed the new file settings.

Start a new file, change the Location and the other settings you routinely change, and Save it as a Template.
Then start your new files using it.

Any luck?

Just to add to @John_Brock’s answer, the Templates are only used when creating new documents. Changes to the Templates do not propagate to pre-existing documents.

That means old documents where you changed the location will have that change, ones where you didn’t make any change will have the previous default. Changing the template won’t alter that, only future documents.

1 Like

I understand what a template does, what I don’t understand is that if I create a new document with a template that does not have the appropriate location, there is no way to change after to the desirable location?

Thank you.

it holds the North offset:
It holds the time zone:

and it resets the location:
If it is not an error and it has been designed like this it’s obviously wrong.

Try following these steps:

First fix a template. I’m going to work with “Small Objects - Millimeters”.

Create a new document, choosing that template.

Go to the Tools Menu and open Options

  1. Select Location page
  2. Find a suitable spot, I’m choosing London
  3. Click Here
  4. Click OK

on the File menu, choose “Save as Template”

Pick the template you are updating, here (of course) I’m choosing “Small Objects - Millimeters”. Be absolutely sure to pick the same template you started with! Then click save

Rhino will ask if you want to save the template. Provided it is the right one, click Yes

IMPORTANT Note: You might prefer to save the template with a new name (like “Small Objects London - Millimeters”) That way there is no risk of future updates overriding it.

Now you have a template located at London. Time to experiment.

Create a new document. Pick the modified template as the basis.

Do some drawing, whatever. Can’t wait? Just open the Sun panel and scroll down to Location:

Look, it says “London”: changing the template worked!

Of course there may be other things that you need to change at the same time. This was basic, but the principle is the same. You also need to repeat for all the other templates you need located in London (or wherever).


@jeremy5 thank you for your time but this doesn’t make sense. I tried and I confirm it holds the location if you start from a blank template at which you have saved the location and start a new drawing from that.
But why my location should be part of the template? I have a project in Armenia, one in Greece, and another in the USA (school projects). And I worked on them the last Semester. They have more than geometry. Saved views, cplanes etc. I want to change the location of these files permanently. Three files in three different locations. Location is a document property, not a rhino property. How is it possible after changing it, at whatever file and pressing save, when I reopen the file the location is somewhere else?
@John_Brock how do you consider this is not a bug? It’s a document property that’s true. So you cannot change document properties after starting a file from a template? Why I can change units? Why I can change annotation styles? They are also document properties. Its a bug and please report to fix it.

Hi Erotokritos -

We’d need to be able to reproduce this behavior to be able to fix it, and, so far, this is not happening when I try that here. I download a random 3dm file that was posted on this forum, open it, change the location, exit Rhino. When I then launch Rhino again, and open that file, the location is still the same as what I set it to.

Please post the output of the Rhino SystemInfo command and a simple 3dm file that shows the behavior on your end.

At least this answer makes sense. Because the previous mention that as expected behavior. I will report in ten minutes.

@wim it seems to be file specific problem. Can I send you the file to investigate?

Sure. The better way is to upload the file to tech support and copy the url to this thread in the comments field. That way, if I get stuck on other things, someone else in the organization can take a look.


I’ve put this on the list as RH-77069 LocationSettings: Change of Location doesn’t stick

Apparently, setting the location to what you want and closing the dialog, then immediately opening the dialog and changing it once again makes this work. For the time being, that would be a workaround.

Hi @wim,

Umm, maybe we all need to read the help for the location page…

If you want to set a location from the list, just click on it so it is highlighted and click OK.

Sorry for contributing to the confusion, @ar00302.


1 Like

Thanks for investigating. In my rhino this trick doesn’t seem to work either.

Hi Jeremy -

I’m afraid I don’t understand what you mean by that.

I’m not able to reproduce this issue from scratch on my system, and the file that you sent has a link to a missing block definition file, that appears to be a SketchUp file(?). It’s possible that things behave differently when that file is found, but you’d have to post or upload that file for me to be able to check that part.

You and I have both said to select a location from the list, then press Here. That is wrong - as I said above, just highlight the location and click OK.

Pressing Here causes the location selected in the list to be overridden by something called the System Location (in my case that appears to be London). You see the red dot on the map shift away from the chosen location when you do this.

Where did I say that?

In the Youtrack instructions to reproduce the error

and in the Notes in the attached sample file.

Yes, I wrote “Press the Here button”.

I did not write:

I think I’m just completely not understanding what you are trying to say.