About the sun

I wonder if there is an option to change default position and other setting of the sun? Now, every re-opening of a file moves me back to California. I know, my place isn’t that cool but still I like it. The more, I have some projects here to do. For now I export settings to a *.rsun file but still it is an additional work, can it be done some automatic way? I have checked the advanced Rhino options, but found nothing similiar…
And the second question, is it possible to set two different sun settings for two different detail windows at a layout? It would be much helpful.
Cheers, Jaro

Hi Jaro - Sun is a document property if you set up a template file with the sun where you like it, that should be in pace when you open the file or set it as your default template to open on New.


Hello Pascal,
Thank you, but it doesn’t work. The problem is whenever I open a file with sun position given by me, it is set back to default position (and by the way, it’s Seattle, not California). Of course, after changing sun position I save the file. I can check if different position set in template file will work.
Cheers, Jaro

So, you set a sun position , save and close the file and when you re-open the file the sun (geographic location) is not where you set it, is that correct?


Yes, this is what I mean.
edit: the problem is with both Rhino 5 and 6, and this is not because of my settings, at the 25-computer lab it was the same.

Hi jaro - I do not see this here - what do you see with this file:

NotSeattleSun.3dm (37.0 KB)


The very first operation, still Seattle:

Cheers, Jaro

Hi Jaro - hmm. Please run the SystemInfo command in Rhino and copy/paste the results here.


Pascal, here it is:

Rhino 6 SR25 2020-4-23 (Rhino 6, 6.25.20114.05271, Git hash:master @ f35d7ded15ec317635ced435d8df84327397038d)
License type: Komercyjna, build 2020-04-23
License details: Cloud Zoo. In use by: Jarek Bakowski ()

Windows 10.0 SR0.0 or greater (Physical RAM: 12Gb)
Machine name: ARCHN

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro 600 (NVidia) Memory: 1GB, Driver date: 1-13-2018 (M-D-Y). OpenGL Ver: 4.5.0 NVIDIA 377.83

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 2x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 1-13-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.25.20114.5271
C:\Program Files\Geometry Gym\Rhino3d\BullAnt.rhp “bullant”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Users\jAR\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\ClippingBox (4dfff1df-5f09-43ae-a044-77b115244b02)\\Rhino 6\ClippingBox.rhp “ClippingBox”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Users\jAR\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Flamingo nXt 5.0 (fd53f8c4-546d-47d1-8820-e66c97645a97)\5.5.18347.11581\5.5\Legacy\Flamingo.Legacy.dll "Flamingo nXt Legacy File Reader " 5.5.18347.11581
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”
C:\Users\jAR\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.9.26.937\SectionTools.rhp “SectionTools”
C:\Users\jAR\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Flamingo nXt 5.0 (fd53f8c4-546d-47d1-8820-e66c97645a97)\5.5.18353.6521\5.5\Flamingo.nXt.rhp “Flamingo nXt 5.5” 5.5.18353.6521
C:\Users\jAR\AppData\Roaming\McNeel\Rhinoceros\packages\6.0\ColorPicker\6.0.0\ColorPicker.rhp “ColorPicker”
C:\Users\jAR\AppData\Roaming\McNeel\Rhinoceros\packages\6.0\PanelingTools\2018.12.17.906\PanelingTools.rhp “PanelingTools”
C:\Users\jAR\AppData\Roaming\McNeel\Rhinoceros\packages\6.0\raytraced-blend-material\1.3.0\RaytracedBlendMaterial.rhp “RaytracedBlendMaterial”
C:\Users\jAR\AppData\Roaming\McNeel\Rhinoceros\packages\6.0\rhino-render-next\0.0.2\RhinoRenderNext.rhp “Rhino Render Next”

Cheers, Jaro

Hi Jar o - thanks. So many plug-ins. Can you please try opening Rhino in Safe mode and see if the problem persists?

To Start Rhino in Safe Mode: Windows start menu, type in ‘Rhinoceros’ and look for the ‘Rhinoceros in Safe Mode’ entry.


Rhino in safe mode doesn’t want to show the sun panel.
I can uninstall some of the plugins and I will let you know.
Cheers, Jaro

Ah yes of course… sorry, I was not thinking. Disable some third party plug-ins, relaunch Rhino, but make sure to load the RDK ones (Renderer Development Kit)



In safe mode your file location was somewhere in the middle of the USA. Opening my template shows good position. So it must have been some plugin… Thank you :slight_smile:
What about the second question? about different settings in different detail windows?
Cheers, Jaro

Hi Jaro -

I do not see how that can work - there is only one sun per document.