List of Diamond chart component fails in Fitness Values

Hello everyone, I hope you can solve this problem that I saw working on Wallacei Analytics; I don’t know if it is a bug problem or is related to calling the values.

I am working on a project for my master’s thesis, and right now, I am setting up the output graphs.

Wallacei is amazing in showing data analytics; the problem is that when I want to use the diamond component to get the fitness values ​​and the graph, only one of them matches my values.

As I show in the image, I have placed the values ​​obtained from the results; these were obtained from the phenotype node.

I thought I had made a mistake mapping the values, so I checked it in the UI analytics, and it showed me the same errors. However, a detail that confused me a bit is the inversion of the values ​​that; in the beginning, I thought I was doing it wrong, but when I tried to place it as it appears in the graph, it appeared to me that it was out of range.

I hope you can guide me regarding this, which apparently is a bug; if you have had something similar, I would appreciate it if you could tell me how you could solve it.

Hi Luis,

It seems you are inverting your ‘Mass’ fitness objective in the ‘Diamond Fitness Chart’ component in Wallacei analytics. I don’t know what settings you are currently inputting into your diamond chart component (if you send me a screenshot of your GH file that would help), but that seems to be the issue. You can learn more about data inversion on pages 58 and 59 of the Wallacei Primer, which you can download here:

1 Like

Yes I think it was a problem with the study because now that I ran a new one, the result were OK, so I think when this happens I only need to re- run and with that It will solve the problem.