Linked .rui - it's a mess

I am experimenting with setting up some toolbars now, so expect more posts like this one going forward.

I created an .rui with some toolbars from V7 (14 actually), and opened (linked) it in V8. All the toolbars open massively too big with lots of unused space. “Size to content…” doesn’t. It works vertically, but leaves far too much blank space on the right side. Plus I have to do that 14 times, one for each toolbar.

OK, that tedious task done, I created a new toolbar button that resides in default and used it to link to one of the toolbars in the .rui library that I now have open. That part actually works fine, hitting the button brings up the linked toolbar even if it is in a different library. I was curious however what would happen if I closed the .rui. I was pretty sure the link wouldn’t work anymore, but I wanted to find out. Went into Options>Appearance>Toolbars and closed the .rui. Then tried the toolbar button with the link - of course it no longer worked, hypothesis confirmed.

I assumed it would start working again if I re-opened the .rui - which it did. HOWEVER… All the toolbars in the .rui were previously open and correctly resized before I closed it - on reopening all of the toolbars in the .rui are now closed again:exploding_head: Go back into Window>Toolbars, switch to the .rui library, and start checking the 14 boxes to get them open again. Now, they all open one on top of each other, and completely incorrectly sized again… Even more hilarious, when you open the first toolbar, it partially covers the checklist box that you are working in, so to check a second toolbar in the list, you have to move the first one out of the way… The more you open the more they cover the checkboxes until you can’t check them anymore. Bravo!!! Who programmed this thing?

OK, I discovered that if you click somewhere in the toolbars window the open toolbars get sent to back, so oyu can continue to open the others. Still a bad design though. Plus, why isn’t there a “check all” box?