Toolbar advice needed

I want to create a toolbar with 2 buttons.
Button 1 should do “! A” for left click, “! B” for right click.
Button 2 should execute “! C” for left click.
The button images are SVG files.
At the end I need a file to give to other users.

I assume this can be a rui file, I’m not sure anymore.
The ‘install’ procedure should be simple, at best drag&drop into Rhino.

I have made several attempts now.
And have read ‘everything’ in the help about containers, macros, libraries, toolbars, buttons, panels, etc.

I can’t get a file that is independent of some unknown other settings or the like.
Now I could describe in detail what I did (obviously not correct).
Would’nt make much sense.

How about the other way around?
The creator(s) of the new system in V8 could give a step-by-step instructions on how to get a deployable toolbar.
Should be easy for the creator!

Like this:

  1. _reset to factory defaults

That would help!

The attached should drag and drop.
After that, go to Window > Toolbars… and choose charles from the dropdown and check charles_01

by default all the toolbars are unchecked on opening, This seems to be a bug imo.

charles.rui (3.7 KB)

Thanks for your effort @Gijs!
Helps a lot for today.

For the future I’d like to know the workflow (not urgent).
I’m puzzled with the details…

On drag&drop of the rui file, it looks like nothing happened.
Some feedback would be nice, a msgbox like

At least it doesn’t do any harm when I drop the rui a hundred times.

When this toolbar is so small that it shows the chevron, the menu doesn’t show the icons.

Haha, I have found a better way:

This results in a rhc file.
Then I made _Reset.
Dropping the rhc file gives an immediate result, exactly as expected.

The rhc file could have an icon and filetype, like for rui.

Correcting myself…

@pascal @JohnM

I now altered the example toolbar to my needs, a have set the pictures and commands.
In the Macro Editor I doublechecked that it is ok what I have done.
And saved the container as a rhc file.
Initial tests were good, on drag&drop I had the wanted toolbar in a container, even after _Reset.

Now I tried again and all my work is gone.
No idea what happened!

I inspected my rhc file with XML Notepad.
The macros I made are still there, but this is not seen in the toolbar.

Also I see the node ‘referenced_rui_files’.
Aha, means the rhc is not enough, I need the rui as well.

The source node tells me this is the referenced rui file:

When I check the Toolbars dialog, I have interesting libraries.

I was really willing to understand and use the new system.
Seems I have no chance:

Reminds me of this...

The Trial - Wikipedia

I give up.

1 Like

@Charles it would be helpful if you give clear steps how to reproduce.
For me it was the first time I tried this container export and found it attaches an id to the name. In your example, it looks to me the id is attached twice.
Can you send me the rhc file that fails?