Linear Light crashes Rhino

make a Linear Light
turn Raytrace on
crash
every time

any thoughts?

Hi Yelen - these steps don’t make Rhino crash on my system. Could you run the Rhino SystemInfo command and post the results here?
Thanks!

it’s bizzare! I tested on the WIP & no prob!
here’s the system info:

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Educational, build 2019-02-27
License details: Cloud Zoo. In use by: Yelen Aye ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: YELEN

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 (NVidia) Memory: 8GB, Driver date: 10-27-2017 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 388.13

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-27-2017
Driver Version: 23.21.13.8813
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Geometry Gym\Rhino3d\BullAnt.rhp “bullant” 1.3.7.0
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Users\yelen\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot7RhinoPlugin (486807a0-d332-4669-8086-e0497d91acd5)\1.6.0.0\KeyShot7RhinoPlugin\Rhino 5.0\KeyShot7RhinoPlugin.rhp “KeyShot7RhinoPlugin” 1.6.0.0
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\yelen\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot8RhinoPlugin (6c7d7caf-b4ba-406d-bfaa-8d719d8212c3)\1.0.0.0\KeyShot8RhinoPlugin\Rhino 5.0\KeyShot8RhinoPlugin.rhp “KeyShot8RhinoPlugin” 1.0.0.0
C:\Users\yelen\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2017.11.17.800\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Users\yelen\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Lumion LiveSync for Rhino (839d6175-32d1-4ffe-a0a4-b7fb43cf0ff5)\2019.3.5.751\Lumion\Rhino 6.0\LumionPlugin.rhp “Lumion LiveSync for Rhino”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - can you please try disabling this plugins in Options > Plug-ins page and then restart Rhino - any different?

-Pascal

just tried it, still crashes instantly as soon as I turn on the Linear Light
thnx @pascal

Hm… darn, that was my prime suspect… can you also try disabling all the KeyShot plug-ins and restart Rhino? Please make sure on restarting that the Lumion and Keyshot plug-ins are in fact disabled…

-Pascal

still no go
very weird
the scene renders just fine w L Lights in WIP
eg

OK …unlikely it is a plug-in I guess - @nathanletwory - do you have an idea?
Crash on setting a view to Raytraced if a linear light is present (is that correct, @yelenaye?)

-Pascal

yes, that is correct!
(or place Linear Lights, turn them off in the Lights Panel, run Raytraced
, works fine. but if you turn visibility back on while in raytraced mode, ‘crash’ )
thank you!

@yelenaye are you sending in the crash reports for this with the crash reporter dialog that should pop up after a crash?

I don’t see crashes here in 6SR14 release candidate.

I sent 2 back to back and stopped, since consequent crashes would be identical.
thnx @nathanletwory

Did you use the same e-mail address as for your Rhino account? That’ll help me find the correct report from our system.

yes I do :wink:

Thank you :slight_smile:

edit/update: I couldn’t find any crash reports with your e-mail address. I’ll check again after the weekend, in case the crash report processing machine is lazy.

thnx! (the two reports were sent prob 2 to 3 hrs ago)

@nathanletwory do you remember me having the same issue a while ago, I was using Rhino-blend material perhaps it’s the same?

@yelenaye 6SR14 is out. I forgot I had fixed that already for that version. So please update.

no more crashes. thank you !