Rhino+Vray crashes when adding lights

Ok, something is definitey wrong with either vray or Rhino … I’ve been having trouble with rhino crashing for days now when trying to render with rectangular or point lights.
I re-installed vray and Rhino.
Open a brand new scene.
Added a plane
Added three rectangular lights. Hit render … Rhino crashes …
Tried with point lights. Rhino crashes …
I have 32 gb of RAM
What the heck is happening … !?

I’ve been using vray with sun and dome lights for years and never had a problem. The first time I’m using other type of lights and rhino keeps crashing !!

I desperately need help. I’m REALLY stuck !!

What version of V-Ray are you using? They recently issued a Service Release 3 on July 7.

I have the latest service updates of both Rhino and vray. I just updated also my Nvidia drivers.
I’m not sure what else to do …
I can send you a quick sample of my full scene where I was having the crashes. But I don’t think is the scene because like I said I tried with a fresh empty rhino file and still does it. It starts the light caching and pre-passes and half way through it crashes (with no prompt for sending report). If it manages to get to the rendering phase is usually ok.

Wait, did you say SR3 of July 7 ? The only one I know is SR2 of June 30
Which by the way Chaos never notified me and I found out by chance

Yes, it is the third SR, but was technically released on June 30. Here’s a post I made with a screen capture: http://www.professor3d.com/2015/07/new-v-ray-service-release-3/

You may have an illegal setting “somewhere”, so I usually solve weirdness by using the Load Defaults button. More information in this video:

If that does not work, then you can send me your file tomorrow. I’ll take a look.

I’ve tried before with the default options to no avail. I placed the file here:

However I emphasize once again that it’s nothing specific of this scene, it happens also with a scene started from scratch.
I tried adding one light at the time and sometimes it handles tow or three lights but as I keep adding lights it eventually crashes.
I’m talking 5 or 6 light nothing out of the ordinary …
Thanks for looking at this

EDIT: This is getting worse actually … now even crashes with a sun. No w I’m even more lost because I wonder if it has to do with my system and not with vray or rhino. It was working perfectly fine 2 days ago and I haven’t installed or changed anything :frowning:


I opened the file and was able to add / render lights without any issues. Which type of lights are you adding? If you switch the irradiance map mode to single frame does that solve your problem?

IR mode is already as single frame.
Like I said I don’t think it’s the scene anymore. Last night I moved the scene to my laptop and rendered the full scene (40mb) with lots of lights of all sorts and I had no problems. The crashes are in my Desktop. They are rectangular lights about 48"x24" with a 30-40 intensity (default units type). Big space so I need 8 or 10 of them. But it doesn’t matter. I tried an empty scene with point lights and still crashes.
On the other hand, I render other scenes that have only Sun and dome lights with no issues, so I’m really at a loss here.
I would narrow it down to being the system and not Rhino or vray but because it crashes with a generic Rhino message, not the one that prompts you to send a report, I have no clue why it crashes.
I’ve been writing a thread in Chaosgroup forum. You might want to see abit more the history in the last couple of days.
Thanks Matt

First of all, skip the ChoasGroup forum and write directly to their tech support email.

Secondly, I reviewed your file and there are a LOT of odd & random settings. They don’t explain the crashes, but by fixing the list of items below, I was able to get decent renders.

  • no physical camera – turn on
  • camera shutter lowered to 1/15 for better exposure
  • lights at 0.3 / too low! – change to 10 or 15
  • lights : covered by geometry, set to invisible, with no decay, turned off
    specular & reflections – fixed
  • emmissive geometry not needed, use lights
  • no environmental GI / turned off - turned back on
  • material on ceiling – wrong way, flipped
  • material on ceiling – too matte @ .2 – .6 is better
  • material on ceiling, general reflection set at .4, should be 1.0
  • material on walls – none applied

Juan Render / before

Dave Render / after

Your glitches look like normal beginner stuff I used to do, which is typically ‘change every setting randomly.’ I have done several V-Ray courses at lynda.com, so check them out. Here is a link for 10-days free.

I appreciate your effort. Thank you.
Not trying to justify the basic errors … However, many of those ‘random’ settings were actually the result of a bunch of different things I tried and weren’t meant to be left there. Sorry. I know that some don’t make sense. I wasn’t trying to get a nice render, only trying to pinpoint the cause of the crashes. The model was only a quick set of planes extracted from the actual model and I should have checked the normals. I guess it’s the result of pulling my hair for 2 days and nights straight, ha, ha. Anyway thanks for the tips.
As I mentioned earlier, the full model rendered without issues in another machine so it would appear that the model wasn’t the problem.
However, I have 3 slave machines and my desktop where I run Rhino.I tried today turning on DR and click on ‘don’t use local machine’ and the crashes stopped.
What’s your conclusion ?

Are you using ANY COMPUTERS on wi-fi? DRSpawner will not work on wi-fi due to the lag. Use wires and all will be fine. (I mention this in the lynda course at the very beginning)

Also, is there anything running in the background? I’ve had issues with back-up software trying to ‘grab’ a file that is in use.

Finally, is your USB dongle plugged into the workstation where you are working? That has been the most reliable way for me. The license occasionally gets ‘confused,’ so I will unplug the USB and plug it right back in to refresh whatever glitch was happening.

I have a fully wired network, no wi-fi for these machines. I’m aware of the potential problems.
My backups run overnight so that’s not an issue either.
Yes the dongle is in my workstation where I run Rhino.
However, like often happens to me when I’m trying to troubleshoot for days, all the sudden yesterday morning everything was working normally again. It drives me nuts because I’m still not 100% sure about what was causeing the crashes. Now even with the ‘don’t use local machine’ disabled, it doesn’t crash … go figure.
Oh well, in any case, that’s so much for your help.

After almost two weeks of still having constant crashes when rendering, I finally found the problem (I hope): Dynamic memory limit setting.
I have 32Gb of ram way more than enough memory to handle almost any complex scene.
However, You could have 200Gb of ram and wouldn’t make any difference if the the Dynamic memory limit is not set properly in vray system tab.
Vray will use only what you tell it to use with this setting. I always thought that setting it to zero will enable vray to use as much RAM as you physically have. Well, this might be true in Max but definitely doesn’t work in Rhino. There is definitely a bug. And it has caused me 2 weeks of hell …
As soon as I set the limit to a specific number, in my case 24,000 (Mb) I was able to render anything with no crashes and way, (way) faster.
Also, I notice that some of the default visopts have stupid dynamic memory limits like 500. Useless for even a small scene.
I thought I would post my frustrating experience.


That’s strange, my current setting for “Dynamic memory limit” is at 0 and I don’t experience these crashes.
I don’t remember from where this setting comes from, maybe a Max thing I carried over…
Somebody from ChaosGroup (@matt_newberg or @fpedrogo ?) should look into this and give us their recommendation.

Already looked at other possibilities. That change (from 0 to a specific number of Mb) definitely made a difference in my system.
I Have a laptop where I don’t experience the issue with the same file and even less RAM and also tried with the setting at 0 without issues.
I’m still puzzled about the whole thing … At least it works now and I can finish my project.
One thing that it seems to be definitely a factor (in the problematic system) is the use of vray lights. It all started when I added rectangular lights. I never had a problem with vray sun and HDRI dome lights. But I cannot figure out how the lights generate the problem, I can only say that they do.

Rectangular lights require a lot more memory compared to a point source. This is because a rectangular light is simulating an area of light – which includes the greatly increased complexities of the soft shadows and reflections.

I get that. What I don’t understand is why is not crashing on a system with half the RAM and less Dynamic Memory reserved …