Line widths are not working in viewports

I’m in Rhino 8. Line widths are functioning as expected in layout views, but they do not work at all in any viewports. I have tried enabling and disabling print preview. This doesn’t have any effect on line widths. I have tried multiple display modes, including shaded and monochrome. In display options for these display modes I have ensured that “use object width” is enabled for all options (curves, lines, surface edges, etc). Within this menu I can change the scale which effects curve thicknesses globally, but no matter what I do can not get curve widths to display on a per-object level. Changing the print width of curves in their properties does nothing to their displayed line width in the viewport. Line TYPES do function, but line WIDTHS do not.

I’ll assume you have the PrintWidth command turned on?
What service release are you running?
PrintWidth display is working for me in model views.

In Rhino 8, there’s the legacy “print width” system that requires PrintDisplay to be turned on. [I take it that’s what JB means by the “PrintWidth command”]. In addition, the linetype now have width settings, that can be set to either physical units or pixels. Those widths don’t require PrintDisplay.

From your description, it’s not clear which one of those workflows you are using.
Also, please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Rhino info tells me I’m running Version 8 SR4 (I think 8.4.240441). PrintWidth is not a recognized command in my version of Rhino. PrintDisplay is enabled, but nothing about width.

system info:
Rhino 8 SR4 2024-2-13 (Rhino 8, 8.4.24044.15001, Git hash:master @ 5d3f86ffffae3c2ed84d21147c008b3907a40a2e)
License type: Educational, build 2024-02-13
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 15GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3070 Laptop GPU (NVidia) Memory: 8GB, Driver date: 10-11-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 545.84
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3070 Laptop GPU (NVidia) Memory: 8GB, Driver date: 10-11-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 545.84
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 11-1-2022 (M-D-Y).
> Integrated accelerated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-11-2023
Driver Version: 31.0.15.4584
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter” 5.1.1.0
C:\Users\noaha\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.23345.954
C:\Users\noaha\AppData\Roaming\McNeel\Rhinoceros\BlockEditNew\BlockEditNew.rhp “BlockEdit” 1.0.0.0
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V8\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

PrintDisplay is enabled. In my display mode settings I have all lineweights set to use object width. I can select a particular line and set it’s PrintWidth to anything I want in the properties, but those changes are not visible at all in my viewport.

I’m just using the “continuous” line type. All of my linetypes are set to use pixels for their width (i’m not trying to change the line width in that menu. I’m changing the print width in the curve (or layer) properties)

Please post and small sample 3dm file.
Also, see if V8 SR5 (released yesterday) works better.

Try this please:

  1. New model using the Default Wireframe working display mode
  2. Draw a curve on the Default layer
  3. In the Layer panel, set the Print width to 0.5mm
  4. Run PrintDisplay and turn it on

Thanks

Updating to SR5 may have fixed it. Either that or I was doing something wrong. The print width is working now, it’s just the scale that’s wrong. I have to change the print width to something ridiculous like 200 in order for there to be a noticeable difference. Once I do that, however, I see that line widths are displaying in the view port.

I think another fix effecting line width may have gone into SR6. In Rhino Options > Updates and Statistics, you can check your Update Frequency to “Service Release Candidate”, then click the “Check now…” button if you want to try it.
Or you can wait until
I recall needing to kick up the scale setting in PrintDisplay in earlier builds.
I’m running an in house build, but tested it in SR5 before responding.