Line to stay on start level

How to get line / curve to stay on start level when watching from top side back etc…
Project pushes it to the ground plane. I want same but stay on start level when drawing from top.



this is what I want


Is there some key to press at the same time?
What does that planar osnap do?

I think smart track is not an option…
Setpt or align is not option. I want it immediately so that I don’t have to use any other commands.

Thanks :slight_smile:

Set Planar to on (I recommend leaving on all the time), then toggle the Project osnap to on after setting your first point. All succeeding points will be on the same Z level as the first point.

Hi Wagner -
… or - Place your first point. Hover over the second point, allowing it to snap. Press the Ctrl key and LMB-click on that second point. Then move the mouse back to the first point and LMB-click.

1 Like

Thanks, that was also nice to learn, but difficult if drawing polylines / polycurves.

Thank you, it works nice.
Can I make keyboard button to turn that project on/off?
I tried but it wanted to make normal project operations…
There is F9 snap “almost like” that…

Yep, under the key combo you want (or an alias) put

'_ProjectOsnap _Toggle

That will toggle Project on or off.

Wow, Great, thank you :slight_smile: