Line thickness

Ive tried to search the forum and elsewhere for this issue with out any luck. Basically ive just starting to investigate the new features of v6, and one of the first major problems ive come across is the thick lines (evens when set to 1 in the display settings) that are much thicker than in v5. Since our office is movein more and more towards drafting in 2d inside rhino instead of eg autocad or microstation its really critical that we can have the thin lines being displayed as in v5. could someone please help me out here and (hopefully) just direct me to the setting i need to fix to get this?



Hi troels - here’s what I get with one pixel curves on my screen

4k screen -

‘regular’ screen

I take it you see something different?




here are the difference - its both with 1 px lineweights! - its same problem with edge curves and isocurves!

Same issue here


Both images are screenshots from the same monitor, 1920x1200 Dell.
Same zoom, both wireframe display default, curve set to 1 pixel width,
is there an adjustment where V6 can be toned down to match the crisp V5.

Are you running on a 4K display for your tests (or at a text scaling > 100%)? I try to account for high DPI situations and may have made the curves a little too thick in this situation.

Not sure if your response is to me too, some extra info anyway…

im on a dell 7510 precision laptop


  • would it be possible to allow control of the way the lineweights scale as you mention? - its really crucial to us when we use Rhino for 2d drafting architectural plans that some lines are really thin since thats the way they will come out when printed.

I see that here too.

1 Like

I’ve spent a lot of time attempting to get high quality line work using our new wire drawing algorithms in V6 and am sure I’ll spend plenty more :slight_smile: I probably won’t have this any better for the initial release of 6.0 (hard to say), but I will continue to work on the wire drawing code and will hopefully have this improved in an early service release.

Thanks Steve.

@Troels_Madsen , @DanBayn, @BrianM , Steve added a test command for the next release-


so you can play and find the right setting - looks like maybe .8-.9 range might be v5-like, but if you can, please have a try and see what looks best for you - let us know!. The command does not autocomplete, you must type the whole thing.

It appears this is not persistent, so for now, if you find a setting you like, you can add a macro to your start-up commands in Options > General something like this

testWireThicknessScale Enabled=On Scale=.85 Enter



Personally I have to say that I liked the thicker lines since the first time I used the WIP. Use it on 1920x1080@23" and 2560x1440@25". Both look very nice to me. Also I haven’t spotted any differences between AMD and nvidia cards. Can’t tell no difference even with anti-aliasing. Had used both AMD and nvidia on the higher resolution display.
I never tried scaling, always use 100% on win10. Would only do it if I got a really high DPI display where 200% scaling makes sense.

1 Like

hI Pascal - THANK YOU! - im really looking forward to test this - when will it be issued?

Hi Troels - that I do not know, we’re kind of on ‘go-slow’ this week it seems.




Thanks @stevebaer and Pascal, for enabling a match to V5 display. This is a very nice feature
which allows thicker lines on the fly, without the need to create a displaymode.

At this stage, a good wire scale setting for my 1920x1200 screen is between 3 and 5.


This is a nice tool. Personally I like 0.6 but each of our users can custom tailor this to suit their preference. This would be a nice addition to the options.



This is great! Not only solves the thick default lines problem in V6 (I like it around 0.6 since it’s closest to V5 over here) but I can also see how it could be useful to temporary make the edges more pronounced for everything when taking hi-res screencaptures without messing with each object type in displaymodes…

Thanks @stevebaer for adding this. Hope one day it gets promoted to real command or integrated into UI (maybe under Options > VIew > OpenGL settings?)


Great to hear this is working for you guys. I’ll look into making this an application setting that you can set using the advanced options dialog as the next step.


works great to be able to set the value according to your own preference - it would be great if “PrintDisplay” = on would work together with the new option - when i run it now it seems to ignore the testwirethicknessscale command?

hi - sorry to be chasing this topic so much but its since we use this every day - are there any ideas regarding when the wirethickness will be fully integrated and/or when “Printdisplay” will work with wirethickness turned on?

thank you!