Layout border surfaces saving to PDF as isocurves only in Rhino 7

I am starting to get frustrated with Rhino 7 that I can’t get back to the simple operability of Rhino 5, perhaps because I didn’t transition through Rhino 6. I have a checkered border in my standard layout created by interspersing black surfaces. When saving out to PDF, only the isocurves are retained, not the surfaces (see screen and PDF images attached). I am sure the solution will be simple for one that knows but the Help hasn’t helped me. Also, I don’t like the thick lines that appear in the on-screen layout but I haven’t found a way to change this feature. Any help would be greatly appreciated.Screenshot 2021-03-27 at 19.49.13 Screenshot 2021-03-27 at 19.49.43

Hello - are you exporting as raster or vector?


As a workaround, could you make the checkered border out of solid hatches instead of surfaces?

1 Like
  1. It makes no difference if I export as vector or raster, the surface is not visible.
  2. Helvetosaur’s suggestion to use solid hatches instead of surfaces works when exported as raster.
  3. At first view, it looks like Rhino 7 Mac is still in beta. I hope I’m not going to have to come back and pester every couple of days to find workarounds for operations that worked fine in previous versions, as this issue is not the only difficulty I’m encountering.

Hmm, here it works with vector printing as well - but I’m on Windows using Rhino PDF. I would always use hatches and not surfaces for doing this type of thing anyway.

TestHatch.pdf (44.6 KB)

Many thanks for the hatching tip.

Printing to PDF with the same settings as you used (Vector + Display Color) on the mac does not produce a solid hatch, just the isos.

Hmm, well, if I recall correctly, printing to a PDF in MacRhino uses the Mac native PDF printer and not the Rhino specific one that needed to be created for Windows Rhino (because there is no native PDF printer in Windows). Maybe the Mac PDFworks differently.

I don’t understand your comment on ‘isos’ concerning hatches, hatches do not have isocurves, only surfaces do. If I understood correctly, solid hatches do not print in vector mode on Mac? Do you see anything at all?

You are correct. I apologize for wasting your time. I must have opened the wrong test file, which still possessed surfaces in the border. With hatching only, both raster and vector output correctly.

Many thanks for your help.