Layout - Annotations, text and lines disappear, background goes white

This has happened to me a few times. A layout suddenly hides or deletes most (but not all) of my annotations, text, curves and blocks and the background goes white. As you can see in the attached image, all that remains are the layout views and an image from my title block.

In the past I’ve found no way to resolve this and have had to create a new layout redo the whole page. This time I was altering some of my custom display mode settings in the options menu. I changed the display mode in a view on another page, switched to this page and accidentally right clicked (which I have set to repeat command) in the space outside the paper space. In the past, this has happened when hitting ctrl+z while in blockedit mode.

Any idea what’s going on here?

In case it helps, here is my system info:
Rhino 6 SR19 2019-10-22 (Rhino 6, 6.19.19295.01001, Git hash:master @ 0af62045bd35259d4c2367dbf7f9ef94ded29299)
License type: Commercial, build 2019-10-22
License details: Cloud Zoo. In use by: Josh Beck (Solomon Group)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-LSEBQ39

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro M4000 (NVidia) Memory: 8GB, Driver date: 11-12-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.28

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-12-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - when this happens, please try restoring the default display settings for the effected layout (or details) Does that change anything? And if you Save , in this state, does closing Rhino and reopening the file sort it out? If not, please send us a file saved in the bad state (to, with a link back here in your comments)


Thanks Pascal.

I tried both approaches and neither solved the issue. I have emailed a file that was saved on the offending page.

Hi Josh - thanks - all annotations show as the file opens here… so, the stuff that goes missing is all on the layout, none inside the details in model space, correct? Do you remember what the other display mode was that seemed to set this? 'Cause, if you put a layout into a display mode (with the right click) that is not showing annotations but otherwise looks the same, it could do exactly this…?


Interesting. So you can see everything?

Yes, all of my annotations were made in the Layout tab, not the model space. Additionally, if I paste any annotations from another page, or try to create new ones, they do not appear.

I was using a customized version of the Technical View, which I have saved as a new style. Is it possible to give a Layout a Display Mode? And if so, is it possible to change it back to default? SG TECHNICAL - NO SHADING.ini (11.5 KB)

I went in to the Display Mode settings and deleted the custom style, but this did not solve the issue. TI will attach the custom display mode here to see if this might cause the issue.

Hi Josh,
This is a known issue that we believe is fixed in the 6.21 release candidate.
It was logged as issue RH-51535 in our system.

In the past, this has happened when hitting ctrl+z while in blockedit mode.
I will try to duplicate it here. I have the Quadro M2200.
Typically, if you save and and reopen the display of all objects will be restored.

Can you test the 6.21 release candidate for us?
Set your Option -> Updates to Service Release Candidate , check for and install the latest and let me know.

Thanks for reporting this.

Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA

1 Like

Thanks Mary Ann.

I installed the service update but it didn’t resolve the layout issue. Is there something additional I should do following the install? Or will this not resolve past issues, but prevent future ones?

Hi Josh,
Thanks for the update and your help.

  • Can you make it happen on demand on your computer?
  • Can I get a list of steps and file, so I can try and reproduce it here?
  • Did reopening the file, bring back all the geometry that disappeared from the display?

Or will this not resolve past issues, but prevent future ones?
The release candidate has been through a few weeks of testing, and will be the public release the following week it all goes well. It is pretty safe to run. But it will update all week, until the release, which can get irritating to some users… Setting your Options to Service Release is always safer because it has been thought more testing. But it will not have the latest fixes that we are looking for in regards to this issue.

Feel free to email the file or dropbox link to me direct

Mary Ann Fugier

Hi Mary Ann.

  • I can’t make it happen on demand, seems random.
  • I will upload a file soon with the steps used to create the problem
  • This did not resolve the issue.

Further, another person opened this file on their machine and was having this issue with greater frequency than I’ve seen before. It happened several times over the course of a few minutes, sometimes with the exact set of circumstances as had created my issue, sometimes differently. I will outline the steps when I upload the file later. They did not have the release candidate installed, so maybe that’s an issue.

I have this problem, or one very similar. Rhino 7 on Mac. It is killing me.

I try to import the title block into the layout (not model space). It lets me snap to the placement origin to place it, then displays for half a second, then disappears altogether. I have a bunch of title blocks somewhere, but cannot see them or find them.

Lost a whole layout yesterday. It is somewhere, just cannot see it or find it.

Hi Matt3,
I think the block issue is a different problem than the ACI.

Currently we have a bug with blocks on the layout. The annotations in the block use the Model space unit for scale, not the layout unit. For example, I can not insert a MM title block on to my Layout , but the annotation is wacked and uses at the model unit.

To workaround this, I duplicate the TB file and scale the Annotations to the model unit. Then when I insert the TB onto to a Layaout with the same Model unit, the Annotations will insert on the layout correct. However you may need to edit and scale the actual title block borders.

This bug unfortunately was introduced in Rhino 6, and Rhino 7 shipped with out fixing it, so you will see it in both versions. Feel free to PM me your files and I will “fix” them so it will work with your models.

Now the ACI - here are a few more details for how Rhino works with White display color and a White background. There are no “safe guards” currently.

Here are a few details from the Rhino Help:

  • AutoCAD Color Index (ACI) 7 is imported as black when Value (brightness) of the Rhino viewport background color is 128 or greater.
  • Otherwise, it is imported as white.

ACI 7 is a special color in AutoCAD. It displays as black when the viewport background is light, and as white when the viewport background is dark. Rhino does not have such feature.

After the file is imported and the layer color is set to White or black according to the rule above, it does not change.

If the DXF/DWG with layer set to the ACI 7 imports a White with a gray or darker background, it will stays White even if the back ground is changed to White.

You would need to set the background to White, and reimport the DXF/DWG to see it import as black.

I have created a Rhino wish and maybe we will see closer behavior to the AutoCAD ACI in a future Rhino.

Mary Ann Fugier